Thu Aug 25 15:42:33 2011 UTC ()
bebox not support md_post_newfs() and md_post_disklabel() now. Change null-func.


(kiyohara)
diff -r1.55 -r1.56 src/distrib/utils/sysinst/arch/bebox/md.c

cvs diff -r1.55 -r1.56 src/distrib/utils/sysinst/arch/bebox/Attic/md.c (expand / switch to unified diff)

--- src/distrib/utils/sysinst/arch/bebox/Attic/md.c 2011/04/04 08:30:20 1.55
+++ src/distrib/utils/sysinst/arch/bebox/Attic/md.c 2011/08/25 15:42:33 1.56
@@ -1,14 +1,14 @@ @@ -1,14 +1,14 @@
1/* $NetBSD: md.c,v 1.55 2011/04/04 08:30:20 mbalmer Exp $ */ 1/* $NetBSD: md.c,v 1.56 2011/08/25 15:42:33 kiyohara Exp $ */
2 2
3/* 3/*
4 * Copyright 1997 Piermont Information Systems Inc. 4 * Copyright 1997 Piermont Information Systems Inc.
5 * All rights reserved. 5 * All rights reserved.
6 * 6 *
7 * Based on code written by Philip A. Nelson for Piermont Information 7 * Based on code written by Philip A. Nelson for Piermont Information
8 * Systems Inc. 8 * Systems Inc.
9 * 9 *
10 * Redistribution and use in source and binary forms, with or without 10 * Redistribution and use in source and binary forms, with or without
11 * modification, are permitted provided that the following conditions 11 * modification, are permitted provided that the following conditions
12 * are met: 12 * are met:
13 * 1. Redistributions of source code must retain the above copyright 13 * 1. Redistributions of source code must retain the above copyright
14 * notice, this list of conditions and the following disclaimer. 14 * notice, this list of conditions and the following disclaimer.
@@ -92,48 +92,37 @@ md_pre_disklabel(void) @@ -92,48 +92,37 @@ md_pre_disklabel(void)
92 msg_display(MSG_wmbrfail); 92 msg_display(MSG_wmbrfail);
93 process_menu(MENU_ok, NULL); 93 process_menu(MENU_ok, NULL);
94 return 1; 94 return 1;
95 } 95 }
96 return 0; 96 return 0;
97} 97}
98 98
99/* 99/*
100 * hook called after writing disklabel to new target disk. 100 * hook called after writing disklabel to new target disk.
101 */ 101 */
102int 102int
103md_post_disklabel(void) 103md_post_disklabel(void)
104{ 104{
105 /* Sector forwarding / badblocks ... */ 
106 if (*doessf) { 
107 printf ("%s", msg_string (MSG_dobad144)); 
108 return run_program(RUN_DISPLAY, "/usr/sbin/bad144 %s 0", 
109 diskdev); 
110 } 
111 return 0; 105 return 0;
112} 106}
113 107
114/* 108/*
115 * hook called after upgrade() or install() has finished setting 109 * hook called after upgrade() or install() has finished setting
116 * up the target disk but immediately before the user is given the 110 * up the target disk but immediately before the user is given the
117 * ``disks are now set up'' message. 111 * ``disks are now set up'' message.
118 */ 112 */
119int 113int
120md_post_newfs(void) 114md_post_newfs(void)
121{ 115{
122 /* boot blocks ... */ 
123 printf (msg_string(MSG_dobootblks), diskdev); 
124 run_program(RUN_DISPLAY, 
125 "/usr/mdec/installboot -v /usr/mdec/biosboot.sym /dev/r%sa", 
126 diskdev); 
127 return 0; 116 return 0;
128} 117}
129 118
130int 119int
131md_post_extract(void) 120md_post_extract(void)
132{ 121{
133 return 0; 122 return 0;
134} 123}
135 124
136void 125void
137md_cleanup_install(void) 126md_cleanup_install(void)
138{ 127{
139#ifndef DEBUG 128#ifndef DEBUG