Wed Oct 29 17:36:07 2014 UTC ()
Add zfs files to rump userspace sources


(justin)
diff -r1.18 -r1.19 src/sys/rump/listsrcdirs

cvs diff -r1.18 -r1.19 src/sys/rump/listsrcdirs (expand / switch to unified diff)

--- src/sys/rump/listsrcdirs 2014/08/11 22:13:56 1.18
+++ src/sys/rump/listsrcdirs 2014/10/29 17:36:07 1.19
@@ -1,16 +1,16 @@ @@ -1,16 +1,16 @@
1#!/bin/sh 1#!/bin/sh
2# 2#
3# $NetBSD: listsrcdirs,v 1.18 2014/08/11 22:13:56 justin Exp $ 3# $NetBSD: listsrcdirs,v 1.19 2014/10/29 17:36:07 justin Exp $
4# 4#
5 5
6# 6#
7# This script echoes the NetBSD source directories useful for 7# This script echoes the NetBSD source directories useful for
8# rump kernels. 8# rump kernels.
9# Feed the output to whichever method you use to obtain NetBSD sources, e.g. 9# Feed the output to whichever method you use to obtain NetBSD sources, e.g.
10# 10#
11# ./listsrcdirs | xargs cvs -d anoncvs@anoncvs.netbsd.org:/cvsroot -z3 co -P 11# ./listsrcdirs | xargs cvs -d anoncvs@anoncvs.netbsd.org:/cvsroot -z3 co -P
12# 12#
13# Note: after making changes, test that "sh listsrcdirs all | sort | uniq -d" 13# Note: after making changes, test that "sh listsrcdirs all | sort | uniq -d"
14# returns an empty set. 14# returns an empty set.
15# 15#
16 16
@@ -92,26 +92,27 @@ lsrc usr /bin/ rm rmdir @@ -92,26 +92,27 @@ lsrc usr /bin/ rm rmdir
92lsrc usr /sbin/ cgdconfig chown 92lsrc usr /sbin/ cgdconfig chown
93lsrc usr /sbin/ disklabel dump 93lsrc usr /sbin/ disklabel dump
94lsrc usr /sbin/ fsck fsck_ext2fs fsck_ffs fsck_msdos 94lsrc usr /sbin/ fsck fsck_ext2fs fsck_ffs fsck_msdos
95lsrc usr /sbin/ ifconfig mknod 95lsrc usr /sbin/ ifconfig mknod
96lsrc usr /sbin/ modstat mount 96lsrc usr /sbin/ modstat mount
97lsrc usr /sbin/ mount_ext2fs mount_ffs mount_msdos mount_tmpfs 97lsrc usr /sbin/ mount_ext2fs mount_ffs mount_msdos mount_tmpfs
98lsrc usr /sbin/ newfs newfs_ext2fs newfs_msdos 98lsrc usr /sbin/ newfs newfs_ext2fs newfs_msdos
99lsrc usr /sbin/ ping ping6 raidctl reboot 99lsrc usr /sbin/ ping ping6 raidctl reboot
100lsrc usr /sbin/ rndctl route setkey sysctl umount 100lsrc usr /sbin/ rndctl route setkey sysctl umount
101lsrc usr /usr.bin/ kdump ktrace 101lsrc usr /usr.bin/ kdump ktrace
102lsrc usr /usr.sbin/ arp dumpfs ndp npf pcictl vnconfig 102lsrc usr /usr.sbin/ arp dumpfs ndp npf pcictl vnconfig
103lsrc usr /usr.sbin/ wlanctl 103lsrc usr /usr.sbin/ wlanctl
104lsrc usr /external/bsd/ libpcap tcpdump wpa 104lsrc usr /external/bsd/ libpcap tcpdump wpa
 105lsrc usr /external/cddl/ osnet
105lsrc usr /crypto/ Makefile.openssl 106lsrc usr /crypto/ Makefile.openssl
106lsrc usr /crypto/dist/ ipsec-tools 107lsrc usr /crypto/dist/ ipsec-tools
107lsrc usr /crypto/external/bsd/ openssl 108lsrc usr /crypto/external/bsd/ openssl
108 109
109 110
110# If -c is given, use CVS syntax to exclude large subdirectories 111# If -c is given, use CVS syntax to exclude large subdirectories
111# of sys. Otherwise just do it wholesale. 112# of sys. Otherwise just do it wholesale.
112if ${cvsmode}; then 113if ${cvsmode}; then
113 iswanted sys && echo \!src/sys/arch src/sys 114 iswanted sys && echo \!src/sys/arch src/sys
114 115
115 # pick a few useful archs, namely those mentioned in buildrump.sh 116 # pick a few useful archs, namely those mentioned in buildrump.sh
116 for arch in ${ARCHS}; do 117 for arch in ${ARCHS}; do
117 lsrc sys /sys/arch/${arch}/ include ${arch} Makefile 118 lsrc sys /sys/arch/${arch}/ include ${arch} Makefile