Thu Oct 15 20:30:57 2015 UTC ()
Pull up following revision(s) (requested by martin in ticket #992):
	distrib/amd64/ramdisks/common/Makefile.ramdisk: revision 1.11
	distrib/amd64/ramdisks/common/list.ramdisk: revision 1.20
	distrib/i386/ramdisks/common/Makefile.ramdisk: revision 1.12
	distrib/i386/ramdisks/common/list.ramdisk: revision 1.26
PR install/50311: missing gptmbr.bin on ramdisk based installs.


(snj)
diff -r1.10 -r1.10.10.1 src/distrib/amd64/ramdisks/common/Makefile.ramdisk
diff -r1.19 -r1.19.2.1 src/distrib/amd64/ramdisks/common/list.ramdisk
diff -r1.11 -r1.11.10.1 src/distrib/i386/ramdisks/common/Makefile.ramdisk
diff -r1.25 -r1.25.2.1 src/distrib/i386/ramdisks/common/list.ramdisk

cvs diff -r1.10 -r1.10.10.1 src/distrib/amd64/ramdisks/common/Makefile.ramdisk (switch to unified diff)

--- src/distrib/amd64/ramdisks/common/Makefile.ramdisk 2012/10/16 08:23:20 1.10
+++ src/distrib/amd64/ramdisks/common/Makefile.ramdisk 2015/10/15 20:30:57 1.10.10.1
@@ -1,50 +1,51 @@ @@ -1,50 +1,51 @@
1# $NetBSD: Makefile.ramdisk,v 1.10 2012/10/16 08:23:20 apb Exp $ 1# $NetBSD: Makefile.ramdisk,v 1.10.10.1 2015/10/15 20:30:57 snj Exp $
2 2
3.include <bsd.own.mk> 3.include <bsd.own.mk>
4.include "${NETBSDSRCDIR}/distrib/common/Makefile.distrib" 4.include "${NETBSDSRCDIR}/distrib/common/Makefile.distrib"
5 5
6AMD64COMMON= ${.CURDIR}/../common 6AMD64COMMON= ${.CURDIR}/../common
7 7
8.PATH: ${AMD64COMMON} 8.PATH: ${AMD64COMMON}
9 9
10WARNS= 1 10WARNS= 1
11DBG= -Os -fno-asynchronous-unwind-tables 11DBG= -Os -fno-asynchronous-unwind-tables
12CRUNCHGEN_FLAGS= -d "${DBG}" 12CRUNCHGEN_FLAGS= -d "${DBG}"
13 13
14CRUNCHBIN= ramdiskbin 14CRUNCHBIN= ramdiskbin
15 15
16# Use ${.CURDIR}/list only if LISTS was not already defined by the caller. 16# Use ${.CURDIR}/list only if LISTS was not already defined by the caller.
17LISTS?= ${.CURDIR}/list 17LISTS?= ${.CURDIR}/list
18LISTS+= ${AMD64COMMON}/list.ramdisk 18LISTS+= ${AMD64COMMON}/list.ramdisk
19MTREECONF= ${DISTRIBDIR}/common/mtree.common 19MTREECONF= ${DISTRIBDIR}/common/mtree.common
20IMAGEENDIAN= le 20IMAGEENDIAN= le
21IMAGEDEPENDS+= ${CRUNCHBIN} \ 21IMAGEDEPENDS+= ${CRUNCHBIN} \
22 dot.profile \ 22 dot.profile \
23 ${DESTDIR}/usr/mdec/boot \ 23 ${DESTDIR}/usr/mdec/boot \
24 ${DESTDIR}/usr/mdec/bootxx_ffsv1 \ 24 ${DESTDIR}/usr/mdec/bootxx_ffsv1 \
25 ${DESTDIR}/usr/mdec/mbr \ 25 ${DESTDIR}/usr/mdec/mbr \
26 ${DESTDIR}/usr/mdec/mbr_ext \ 26 ${DESTDIR}/usr/mdec/mbr_ext \
27 ${DESTDIR}/usr/mdec/mbr_bootsel \ 27 ${DESTDIR}/usr/mdec/mbr_bootsel \
 28 ${DESTDIR}/usr/mdec/gptmbr.bin \
28 ${NETBSDSRCDIR}/etc/group ${NETBSDSRCDIR}/etc/master.passwd \ 29 ${NETBSDSRCDIR}/etc/group ${NETBSDSRCDIR}/etc/master.passwd \
29 ${NETBSDSRCDIR}/etc/netconfig ${DISTRIBDIR}/common/protocols \ 30 ${NETBSDSRCDIR}/etc/netconfig ${DISTRIBDIR}/common/protocols \
30 ${DISTRIBDIR}/common/services 31 ${DISTRIBDIR}/common/services
31PARSELISTENV+= BOOTMODEL=${BOOTMODEL:Q} 32PARSELISTENV+= BOOTMODEL=${BOOTMODEL:Q}
32 33
33.if defined(USE_SYSINST) 34.if defined(USE_SYSINST)
34LISTS+= ${DISTRIBDIR}/common/list.sysinst 35LISTS+= ${DISTRIBDIR}/common/list.sysinst
35MAKEFS_FLAGS+= -f 14 36MAKEFS_FLAGS+= -f 14
36.endif 37.endif
37 38
38# Use stubs to eliminate some large stuff from libc 39# Use stubs to eliminate some large stuff from libc
39HACKSRC= ${DISTRIBDIR}/utils/libhack 40HACKSRC= ${DISTRIBDIR}/utils/libhack
40.include "${HACKSRC}/Makefile.inc" 41.include "${HACKSRC}/Makefile.inc"
41${CRUNCHBIN}: libhack.o 42${CRUNCHBIN}: libhack.o
42 43
43.include "${DISTRIBDIR}/common/Makefile.crunch" 44.include "${DISTRIBDIR}/common/Makefile.crunch"
44.include "${DISTRIBDIR}/common/Makefile.dhcpcd" 45.include "${DISTRIBDIR}/common/Makefile.dhcpcd"
45.include "${DISTRIBDIR}/common/Makefile.makedev" 46.include "${DISTRIBDIR}/common/Makefile.makedev"
46.include "${DISTRIBDIR}/common/Makefile.image" 47.include "${DISTRIBDIR}/common/Makefile.image"
47 48
48release: 49release:
49 50
50.include <bsd.prog.mk> 51.include <bsd.prog.mk>

cvs diff -r1.19 -r1.19.2.1 src/distrib/amd64/ramdisks/common/list.ramdisk (switch to unified diff)

--- src/distrib/amd64/ramdisks/common/list.ramdisk 2014/08/10 20:07:41 1.19
+++ src/distrib/amd64/ramdisks/common/list.ramdisk 2015/10/15 20:30:57 1.19.2.1
@@ -1,88 +1,89 @@ @@ -1,88 +1,89 @@
1# $NetBSD: list.ramdisk,v 1.19 2014/08/10 20:07:41 riz Exp $ 1# $NetBSD: list.ramdisk,v 1.19.2.1 2015/10/15 20:30:57 snj Exp $
2 2
3SRCDIRS external/bsd/less/bin 3SRCDIRS external/bsd/less/bin
4SRCDIRS bin sbin usr.bin usr.sbin libexec 4SRCDIRS bin sbin usr.bin usr.sbin libexec
5 5
6# Programs for a minimal ramdisk image 6# Programs for a minimal ramdisk image
7 7
8PROG bin/cat 8PROG bin/cat
9PROG bin/chmod 9PROG bin/chmod
10PROG bin/cp 10PROG bin/cp
11PROG bin/ln 11PROG bin/ln
12PROG bin/ls 12PROG bin/ls
13PROG bin/mkdir 13PROG bin/mkdir
14PROG bin/mv 14PROG bin/mv
15PROG bin/pax usr/bin/tar 15PROG bin/pax usr/bin/tar
16PROG bin/pwd 16PROG bin/pwd
17PROG bin/rm 17PROG bin/rm
18PROG bin/sh 18PROG bin/sh
19PROG bin/stty 19PROG bin/stty
20 20
21PROG sbin/chown bin/chgrp 21PROG sbin/chown bin/chgrp
22PROG sbin/disklabel 22PROG sbin/disklabel
23PROG sbin/dmesg 23PROG sbin/dmesg
24PROG sbin/fsck 24PROG sbin/fsck
25PROG sbin/fsck_ffs 25PROG sbin/fsck_ffs
26PROG sbin/gpt 26PROG sbin/gpt
27PROG sbin/ifconfig 27PROG sbin/ifconfig
28PROG sbin/init 28PROG sbin/init
29PROG sbin/mknod 29PROG sbin/mknod
30PROG sbin/mount 30PROG sbin/mount
31PROG sbin/mount_cd9660 31PROG sbin/mount_cd9660
32PROG sbin/mount_ext2fs 32PROG sbin/mount_ext2fs
33PROG sbin/mount_ffs 33PROG sbin/mount_ffs
34# PROG sbin/mount_kernfs 34# PROG sbin/mount_kernfs
35PROG sbin/mount_msdos 35PROG sbin/mount_msdos
36PROG sbin/mount_nfs 36PROG sbin/mount_nfs
37PROG sbin/mount_tmpfs 37PROG sbin/mount_tmpfs
38PROG sbin/newfs sbin/mount_mfs 38PROG sbin/newfs sbin/mount_mfs
39PROG sbin/newfs_ext2fs 39PROG sbin/newfs_ext2fs
40PROG sbin/ping 40PROG sbin/ping
41PROG sbin/reboot sbin/halt 41PROG sbin/reboot sbin/halt
42PROG sbin/route 42PROG sbin/route
43PROG sbin/swapctl 43PROG sbin/swapctl
44PROG sbin/umount 44PROG sbin/umount
45 45
46PROG usr/bin/ftp 46PROG usr/bin/ftp
47PROG usr/bin/gzip usr/bin/gzcat usr/bin/gunzip 47PROG usr/bin/gzip usr/bin/gzcat usr/bin/gunzip
48PROG usr/bin/sed 48PROG usr/bin/sed
49 49
50# One of these is rather useful 50# One of these is rather useful
51# PROG usr/bin/less usr/bin/more 51# PROG usr/bin/less usr/bin/more
52# PROG usr/bin/more usr/bin/less 52# PROG usr/bin/more usr/bin/less
53 53
54# sysinst doesn't use installboot (yet) 54# sysinst doesn't use installboot (yet)
55PROG usr/sbin/installboot 55PROG usr/sbin/installboot
56 56
57PROG usr/sbin/chroot 57PROG usr/sbin/chroot
58 58
59SPECIAL gzip srcdir distrib/utils/x_gzip 59SPECIAL gzip srcdir distrib/utils/x_gzip
60SPECIAL ifconfig srcdir distrib/utils/x_ifconfig 60SPECIAL ifconfig srcdir distrib/utils/x_ifconfig
61SPECIAL ping srcdir distrib/utils/x_ping 61SPECIAL ping srcdir distrib/utils/x_ping
62SPECIAL route srcdir distrib/utils/x_route 62SPECIAL route srcdir distrib/utils/x_route
63# SPECIAL more srcdir distrib/utils/more 63# SPECIAL more srcdir distrib/utils/more
64 64
65# init invokes the shell as -sh 65# init invokes the shell as -sh
66ARGVLN sh -sh 66ARGVLN sh -sh
67 67
68# libhack.o is built by Makefile & included Makefile.inc 68# libhack.o is built by Makefile & included Makefile.inc
69LIBS libhack.o -ledit -lutil -lcurses -lterminfo -lrmt -lcrypt -ll -lm -lz -lprop 69LIBS libhack.o -ledit -lutil -lcurses -lterminfo -lrmt -lcrypt -ll -lm -lz -lprop
70 70
71# various files that we need in /etc for the install 71# various files that we need in /etc for the install
72COPY ${NETBSDSRCDIR}/etc/group etc/group 72COPY ${NETBSDSRCDIR}/etc/group etc/group
73COPY ${NETBSDSRCDIR}/etc/master.passwd etc/master.passwd 73COPY ${NETBSDSRCDIR}/etc/master.passwd etc/master.passwd
74COPY ${NETBSDSRCDIR}/etc/netconfig etc/netconfig 74COPY ${NETBSDSRCDIR}/etc/netconfig etc/netconfig
75COPY ${DISTRIBDIR}/common/protocols etc/protocols 75COPY ${DISTRIBDIR}/common/protocols etc/protocols
76COPY ${DISTRIBDIR}/common/services etc/services 76COPY ${DISTRIBDIR}/common/services etc/services
77 77
78# we need the boot block in /usr/mdec + the MBR copy 78# we need the boot block in /usr/mdec + the MBR copy
79COPY ${DESTDIR}/usr/mdec/boot usr/mdec/boot 79COPY ${DESTDIR}/usr/mdec/boot usr/mdec/boot
80COPY ${DESTDIR}/usr/mdec/bootxx_ffsv1 usr/mdec/bootxx_ffsv1 80COPY ${DESTDIR}/usr/mdec/bootxx_ffsv1 usr/mdec/bootxx_ffsv1
81COPY ${DESTDIR}/usr/mdec/bootxx_ffsv2 usr/mdec/bootxx_ffsv2 81COPY ${DESTDIR}/usr/mdec/bootxx_ffsv2 usr/mdec/bootxx_ffsv2
82COPY ${DESTDIR}/usr/mdec/bootxx_lfsv2 usr/mdec/bootxx_lfsv2 82COPY ${DESTDIR}/usr/mdec/bootxx_lfsv2 usr/mdec/bootxx_lfsv2
83COPY ${DESTDIR}/usr/mdec/mbr usr/mdec/mbr 83COPY ${DESTDIR}/usr/mdec/mbr usr/mdec/mbr
84COPY ${DESTDIR}/usr/mdec/mbr_ext usr/mdec/mbr_ext 84COPY ${DESTDIR}/usr/mdec/mbr_ext usr/mdec/mbr_ext
85COPY ${DESTDIR}/usr/mdec/mbr_bootsel usr/mdec/mbr_bootsel 85COPY ${DESTDIR}/usr/mdec/mbr_bootsel usr/mdec/mbr_bootsel
 86COPY ${DESTDIR}/usr/mdec/gptmbr.bin usr/mdec/gptmbr.bin
86 87
87# and the boot script 88# and the boot script
88COPY ${CURDIR}/../common/dot.profile .profile 89COPY ${CURDIR}/../common/dot.profile .profile

cvs diff -r1.11 -r1.11.10.1 src/distrib/i386/ramdisks/common/Makefile.ramdisk (switch to unified diff)

--- src/distrib/i386/ramdisks/common/Makefile.ramdisk 2012/10/16 08:23:21 1.11
+++ src/distrib/i386/ramdisks/common/Makefile.ramdisk 2015/10/15 20:30:57 1.11.10.1
@@ -1,57 +1,58 @@ @@ -1,57 +1,58 @@
1# $NetBSD: Makefile.ramdisk,v 1.11 2012/10/16 08:23:21 apb Exp $ 1# $NetBSD: Makefile.ramdisk,v 1.11.10.1 2015/10/15 20:30:57 snj Exp $
2 2
3.include <bsd.own.mk> 3.include <bsd.own.mk>
4.include "${NETBSDSRCDIR}/distrib/common/Makefile.distrib" 4.include "${NETBSDSRCDIR}/distrib/common/Makefile.distrib"
5 5
6I386COMMON= ${.CURDIR}/../common 6I386COMMON= ${.CURDIR}/../common
7 7
8.PATH: ${I386COMMON} 8.PATH: ${I386COMMON}
9 9
10WARNS= 1 10WARNS= 1
11DBG= -Os 11DBG= -Os
12 12
13CRUNCHBIN= ramdiskbin 13CRUNCHBIN= ramdiskbin
14 14
15# Use ${.CURDIR}/list only if LISTS was not already defined by the caller. 15# Use ${.CURDIR}/list only if LISTS was not already defined by the caller.
16LISTS?= ${.CURDIR}/list 16LISTS?= ${.CURDIR}/list
17LISTS+= ${I386COMMON}/list.ramdisk 17LISTS+= ${I386COMMON}/list.ramdisk
18MTREECONF= ${DISTRIBDIR}/common/mtree.common 18MTREECONF= ${DISTRIBDIR}/common/mtree.common
19IMAGEENDIAN= le 19IMAGEENDIAN= le
20IMAGEDEPENDS+= ${CRUNCHBIN} \ 20IMAGEDEPENDS+= ${CRUNCHBIN} \
21 dot.profile \ 21 dot.profile \
22 ${DESTDIR}/usr/mdec/boot \ 22 ${DESTDIR}/usr/mdec/boot \
23 ${DESTDIR}/usr/mdec/bootxx_ffsv1 \ 23 ${DESTDIR}/usr/mdec/bootxx_ffsv1 \
24 ${DESTDIR}/usr/mdec/mbr \ 24 ${DESTDIR}/usr/mdec/mbr \
25 ${DESTDIR}/usr/mdec/mbr_ext \ 25 ${DESTDIR}/usr/mdec/mbr_ext \
26 ${DESTDIR}/usr/mdec/mbr_bootsel \ 26 ${DESTDIR}/usr/mdec/mbr_bootsel \
 27 ${DESTDIR}/usr/mdec/gptmbr.bin \
27 ${NETBSDSRCDIR}/etc/group ${NETBSDSRCDIR}/etc/master.passwd \ 28 ${NETBSDSRCDIR}/etc/group ${NETBSDSRCDIR}/etc/master.passwd \
28 ${NETBSDSRCDIR}/etc/netconfig ${DISTRIBDIR}/common/protocols \ 29 ${NETBSDSRCDIR}/etc/netconfig ${DISTRIBDIR}/common/protocols \
29 ${DISTRIBDIR}/common/services 30 ${DISTRIBDIR}/common/services
30PARSELISTENV+= BOOTMODEL=${BOOTMODEL:Q} 31PARSELISTENV+= BOOTMODEL=${BOOTMODEL:Q}
31 32
32# This propogates through to the link of ramdiskbin 33# This propogates through to the link of ramdiskbin
33# The map file is useful when trying to prune the image 34# The map file is useful when trying to prune the image
34LDFLAGS+= -Wl,-Map,${CRUNCHBIN}.map,--cref 35LDFLAGS+= -Wl,-Map,${CRUNCHBIN}.map,--cref
35CRUNCHENV += LDFLAGS=${LDFLAGS:Q} 36CRUNCHENV += LDFLAGS=${LDFLAGS:Q}
36 37
37.if defined(USE_SYSINST) 38.if defined(USE_SYSINST)
38.if ${USE_SYSINST} != yes 39.if ${USE_SYSINST} != yes
39LISTS+= ${DISTRIBDIR}/common/list.sysinst.${USE_SYSINST} 40LISTS+= ${DISTRIBDIR}/common/list.sysinst.${USE_SYSINST}
40.else 41.else
41LISTS+= ${DISTRIBDIR}/common/list.sysinst 42LISTS+= ${DISTRIBDIR}/common/list.sysinst
42.endif 43.endif
43MAKEFS_FLAGS+= -f 14 44MAKEFS_FLAGS+= -f 14
44.endif 45.endif
45 46
46# Use stubs to eliminate some large stuff from libc 47# Use stubs to eliminate some large stuff from libc
47HACKSRC= ${DISTRIBDIR}/utils/libhack 48HACKSRC= ${DISTRIBDIR}/utils/libhack
48.include "${HACKSRC}/Makefile.inc" 49.include "${HACKSRC}/Makefile.inc"
49${CRUNCHBIN}: libhack.o 50${CRUNCHBIN}: libhack.o
50 51
51.include "${DISTRIBDIR}/common/Makefile.crunch" 52.include "${DISTRIBDIR}/common/Makefile.crunch"
52.include "${DISTRIBDIR}/common/Makefile.makedev" 53.include "${DISTRIBDIR}/common/Makefile.makedev"
53.include "${DISTRIBDIR}/common/Makefile.image" 54.include "${DISTRIBDIR}/common/Makefile.image"
54 55
55release: 56release:
56 57
57.include <bsd.prog.mk> 58.include <bsd.prog.mk>

cvs diff -r1.25 -r1.25.2.1 src/distrib/i386/ramdisks/common/list.ramdisk (switch to unified diff)

--- src/distrib/i386/ramdisks/common/list.ramdisk 2014/08/10 20:07:41 1.25
+++ src/distrib/i386/ramdisks/common/list.ramdisk 2015/10/15 20:30:57 1.25.2.1
@@ -1,88 +1,89 @@ @@ -1,88 +1,89 @@
1# $NetBSD: list.ramdisk,v 1.25 2014/08/10 20:07:41 riz Exp $ 1# $NetBSD: list.ramdisk,v 1.25.2.1 2015/10/15 20:30:57 snj Exp $
2 2
3SRCDIRS external/bsd/less/bin 3SRCDIRS external/bsd/less/bin
4SRCDIRS bin sbin usr.bin usr.sbin libexec 4SRCDIRS bin sbin usr.bin usr.sbin libexec
5 5
6# Programs for a minimal ramdisk image 6# Programs for a minimal ramdisk image
7 7
8PROG bin/cat 8PROG bin/cat
9PROG bin/chmod 9PROG bin/chmod
10PROG bin/cp 10PROG bin/cp
11PROG bin/ln 11PROG bin/ln
12PROG bin/ls 12PROG bin/ls
13PROG bin/mkdir 13PROG bin/mkdir
14PROG bin/mv 14PROG bin/mv
15PROG bin/pax usr/bin/tar 15PROG bin/pax usr/bin/tar
16PROG bin/pwd 16PROG bin/pwd
17PROG bin/rm 17PROG bin/rm
18PROG bin/sh 18PROG bin/sh
19PROG bin/stty 19PROG bin/stty
20 20
21PROG sbin/chown bin/chgrp 21PROG sbin/chown bin/chgrp
22PROG sbin/disklabel 22PROG sbin/disklabel
23PROG sbin/dmesg 23PROG sbin/dmesg
24PROG sbin/fsck 24PROG sbin/fsck
25PROG sbin/fsck_ffs 25PROG sbin/fsck_ffs
26PROG sbin/gpt 26PROG sbin/gpt
27PROG sbin/ifconfig 27PROG sbin/ifconfig
28PROG sbin/init 28PROG sbin/init
29PROG sbin/mknod 29PROG sbin/mknod
30PROG sbin/mount 30PROG sbin/mount
31PROG sbin/mount_cd9660 31PROG sbin/mount_cd9660
32PROG sbin/mount_ext2fs 32PROG sbin/mount_ext2fs
33PROG sbin/mount_ffs 33PROG sbin/mount_ffs
34# PROG sbin/mount_kernfs 34# PROG sbin/mount_kernfs
35PROG sbin/mount_msdos 35PROG sbin/mount_msdos
36PROG sbin/mount_nfs 36PROG sbin/mount_nfs
37PROG sbin/mount_tmpfs 37PROG sbin/mount_tmpfs
38PROG sbin/newfs sbin/mount_mfs 38PROG sbin/newfs sbin/mount_mfs
39PROG sbin/newfs_ext2fs 39PROG sbin/newfs_ext2fs
40PROG sbin/ping 40PROG sbin/ping
41PROG sbin/reboot sbin/halt 41PROG sbin/reboot sbin/halt
42PROG sbin/route 42PROG sbin/route
43PROG sbin/swapctl 43PROG sbin/swapctl
44PROG sbin/umount 44PROG sbin/umount
45 45
46PROG usr/bin/ftp 46PROG usr/bin/ftp
47PROG usr/bin/gzip usr/bin/gzcat usr/bin/gunzip 47PROG usr/bin/gzip usr/bin/gzcat usr/bin/gunzip
48PROG usr/bin/sed 48PROG usr/bin/sed
49 49
50# One of these is rather useful 50# One of these is rather useful
51# PROG usr/bin/less usr/bin/more 51# PROG usr/bin/less usr/bin/more
52# PROG usr/bin/more usr/bin/less 52# PROG usr/bin/more usr/bin/less
53 53
54# sysinst doesn't use installboot (yet) 54# sysinst doesn't use installboot (yet)
55PROG usr/sbin/installboot 55PROG usr/sbin/installboot
56 56
57PROG usr/sbin/chroot 57PROG usr/sbin/chroot
58 58
59SPECIAL gzip srcdir distrib/utils/x_gzip 59SPECIAL gzip srcdir distrib/utils/x_gzip
60SPECIAL ifconfig srcdir distrib/utils/x_ifconfig 60SPECIAL ifconfig srcdir distrib/utils/x_ifconfig
61SPECIAL ping srcdir distrib/utils/x_ping 61SPECIAL ping srcdir distrib/utils/x_ping
62SPECIAL route srcdir distrib/utils/x_route 62SPECIAL route srcdir distrib/utils/x_route
63# SPECIAL more srcdir distrib/utils/more 63# SPECIAL more srcdir distrib/utils/more
64 64
65# init invokes the shell as -sh 65# init invokes the shell as -sh
66ARGVLN sh -sh 66ARGVLN sh -sh
67 67
68# libhack.o is built by Makefile & included Makefile.inc 68# libhack.o is built by Makefile & included Makefile.inc
69LIBS libhack.o -ledit -lutil -lcurses -lterminfo -lrmt -lcrypt -ll -lm -lz -lprop 69LIBS libhack.o -ledit -lutil -lcurses -lterminfo -lrmt -lcrypt -ll -lm -lz -lprop
70 70
71# various files that we need in /etc for the install 71# various files that we need in /etc for the install
72COPY ${NETBSDSRCDIR}/etc/group etc/group 72COPY ${NETBSDSRCDIR}/etc/group etc/group
73COPY ${NETBSDSRCDIR}/etc/master.passwd etc/master.passwd 73COPY ${NETBSDSRCDIR}/etc/master.passwd etc/master.passwd
74COPY ${NETBSDSRCDIR}/etc/netconfig etc/netconfig 74COPY ${NETBSDSRCDIR}/etc/netconfig etc/netconfig
75COPY ${DISTRIBDIR}/common/protocols etc/protocols 75COPY ${DISTRIBDIR}/common/protocols etc/protocols
76COPY ${DISTRIBDIR}/common/services etc/services 76COPY ${DISTRIBDIR}/common/services etc/services
77 77
78# we need the boot block in /usr/mdec + the MBR copy 78# we need the boot block in /usr/mdec + the MBR copy
79COPY ${DESTDIR}/usr/mdec/boot usr/mdec/boot 79COPY ${DESTDIR}/usr/mdec/boot usr/mdec/boot
80COPY ${DESTDIR}/usr/mdec/bootxx_ffsv1 usr/mdec/bootxx_ffsv1 80COPY ${DESTDIR}/usr/mdec/bootxx_ffsv1 usr/mdec/bootxx_ffsv1
81COPY ${DESTDIR}/usr/mdec/bootxx_ffsv2 usr/mdec/bootxx_ffsv2 81COPY ${DESTDIR}/usr/mdec/bootxx_ffsv2 usr/mdec/bootxx_ffsv2
82COPY ${DESTDIR}/usr/mdec/bootxx_lfsv2 usr/mdec/bootxx_lfsv2 82COPY ${DESTDIR}/usr/mdec/bootxx_lfsv2 usr/mdec/bootxx_lfsv2
83COPY ${DESTDIR}/usr/mdec/mbr usr/mdec/mbr 83COPY ${DESTDIR}/usr/mdec/mbr usr/mdec/mbr
84COPY ${DESTDIR}/usr/mdec/mbr_ext usr/mdec/mbr_ext 84COPY ${DESTDIR}/usr/mdec/mbr_ext usr/mdec/mbr_ext
85COPY ${DESTDIR}/usr/mdec/mbr_bootsel usr/mdec/mbr_bootsel 85COPY ${DESTDIR}/usr/mdec/mbr_bootsel usr/mdec/mbr_bootsel
 86COPY ${DESTDIR}/usr/mdec/gptmbr.bin usr/mdec/gptmbr.bin
86 87
87# and the boot script 88# and the boot script
88COPY ${CURDIR}/../common/dot.profile .profile 89COPY ${CURDIR}/../common/dot.profile .profile