Tue Aug 2 21:26:59 2011 UTC ()
20110802
	Release 0.4.2.1
	Fixed the "too many connexions" problem with libfetch and FTP


(imil)
diff -r1.13 -r1.14 pkgsrc/pkgtools/pkgin/Makefile
diff -r1.10 -r1.11 pkgsrc/pkgtools/pkgin/distinfo

cvs diff -r1.13 -r1.14 pkgsrc/pkgtools/pkgin/Makefile (switch to unified diff)

--- pkgsrc/pkgtools/pkgin/Makefile 2011/06/20 15:17:02 1.13
+++ pkgsrc/pkgtools/pkgin/Makefile 2011/08/02 21:26:59 1.14
@@ -1,65 +1,64 @@ @@ -1,65 +1,64 @@
1# $NetBSD: Makefile,v 1.13 2011/06/20 15:17:02 wiz Exp $ 1# $NetBSD: Makefile,v 1.14 2011/08/02 21:26:59 imil Exp $
2# 2#
3 3
4DISTNAME= pkgin-0.4.2 4DISTNAME= pkgin-0.4.2.1
5PKGREVISION= 2 
6CATEGORIES= pkgtools 5CATEGORIES= pkgtools
7MASTER_SITES= ftp://ftp.NetBSD.org/pub/NetBSD/misc/imil/ 6MASTER_SITES= ftp://ftp.NetBSD.org/pub/NetBSD/misc/imil/
8 7
9MAINTAINER= imil@NetBSD.org 8MAINTAINER= imil@NetBSD.org
10HOMEPAGE= http://pkgin.net/ 9HOMEPAGE= http://pkgin.net/
11COMMENT= Apt / yum like tool for managing pkgsrc binary packages 10COMMENT= Apt / yum like tool for managing pkgsrc binary packages
12LICENSE= modified-bsd 11LICENSE= modified-bsd
13 12
14PKG_DESTDIR_SUPPORT= user-destdir 13PKG_DESTDIR_SUPPORT= user-destdir
15 14
16EGDIR= ${PREFIX}/share/examples/${PKGBASE} 15EGDIR= ${PREFIX}/share/examples/${PKGBASE}
17CONF_FILES= ${EGDIR}/repositories.conf.example \ 16CONF_FILES= ${EGDIR}/repositories.conf.example \
18 ${PKG_SYSCONFDIR}/${PKGBASE}/repositories.conf 17 ${PKG_SYSCONFDIR}/${PKGBASE}/repositories.conf
19 18
20OWN_DIRS+= ${PKG_SYSCONFDIR}/${PKGBASE} 19OWN_DIRS+= ${PKG_SYSCONFDIR}/${PKGBASE}
21INSTALLATION_DIRS+= bin ${PKGMANDIR}/man1 ${EGDIR} 20INSTALLATION_DIRS+= bin ${PKGMANDIR}/man1 ${EGDIR}
22 21
23WRKSRC= ${WRKDIR}/pkgin 22WRKSRC= ${WRKDIR}/pkgin
24 23
25SUBST_CLASSES+= path 24SUBST_CLASSES+= path
26SUBST_STAGE.path= pre-configure 25SUBST_STAGE.path= pre-configure
27SUBST_MESSAGE.path= Adjusting path. 26SUBST_MESSAGE.path= Adjusting path.
28SUBST_FILES.path= Makefile.in actions.c pkgin.1 27SUBST_FILES.path= Makefile.in actions.c pkgin.1
29SUBST_SED.path= -e "s|/usr/pkg/etc|${PKG_SYSCONFDIR}|g" 28SUBST_SED.path= -e "s|/usr/pkg/etc|${PKG_SYSCONFDIR}|g"
30SUBST_SED.path+= -e "s|/usr/sbin|${PKG_TOOLS_BIN}|g" 29SUBST_SED.path+= -e "s|/usr/sbin|${PKG_TOOLS_BIN}|g"
31SUBST_SED.path+= -e "s|/var|${VARBASE}|g" 30SUBST_SED.path+= -e "s|/var|${VARBASE}|g"
32SUBST_SED.path+= -e "s|/usr/pkg|${PREFIX}|g" 31SUBST_SED.path+= -e "s|/usr/pkg|${PREFIX}|g"
33 32
34GNU_CONFIGURE= yes 33GNU_CONFIGURE= yes
35USE_FEATURES= nbcompat 34USE_FEATURES= nbcompat
36 35
37.include "../../mk/bsd.prefs.mk" 36.include "../../mk/bsd.prefs.mk"
38 37
39# those have official repositories 38# those have official repositories
40.if ${OPSYS} == "NetBSD" || ${OPSYS} == "DragonFly" || ${OPSYS} == "Minix" 39.if ${OPSYS} == "NetBSD" || ${OPSYS} == "DragonFly" || ${OPSYS} == "Minix"
41pre-install: 40pre-install:
42 ${GREP} -i ${OPSYS} ${WRKSRC}/REPOSITORIES >> \ 41 ${GREP} -i ${OPSYS} ${WRKSRC}/REPOSITORIES >> \
43 ${WRKSRC}/repositories.conf 42 ${WRKSRC}/repositories.conf
44.endif 43.endif
45 44
46do-install: 45do-install:
47 ${INSTALL_PROGRAM} ${WRKSRC}/pkgin ${DESTDIR}${PREFIX}/bin 46 ${INSTALL_PROGRAM} ${WRKSRC}/pkgin ${DESTDIR}${PREFIX}/bin
48 ${INSTALL_MAN} ${WRKSRC}/pkgin.1 \ 47 ${INSTALL_MAN} ${WRKSRC}/pkgin.1 \
49 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1 48 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
50 ${INSTALL_DATA} ${WRKSRC}/repositories.conf \ 49 ${INSTALL_DATA} ${WRKSRC}/repositories.conf \
51 ${DESTDIR}${EGDIR}/repositories.conf.example 50 ${DESTDIR}${EGDIR}/repositories.conf.example
52 51
53# libfetch has no builtin.mk and is included in NetBSD>=5 52# libfetch has no builtin.mk and is included in NetBSD>=5
54.if ${OPSYS} != "NetBSD" || \ 53.if ${OPSYS} != "NetBSD" || \
55 (${OPSYS} == "NetBSD" && !empty(OS_VERSION:M[0-4].*)) 54 (${OPSYS} == "NetBSD" && !empty(OS_VERSION:M[0-4].*))
56. include "../../net/libfetch/buildlink3.mk" 55. include "../../net/libfetch/buildlink3.mk"
57.endif 56.endif
58 57
59# Only MINIX doesn't compile SQLite Amalgation source 58# Only MINIX doesn't compile SQLite Amalgation source
60.if ${OPSYS} == "Minix" 59.if ${OPSYS} == "Minix"
61. include "../../databases/sqlite3/buildlink3.mk" 60. include "../../databases/sqlite3/buildlink3.mk"
62.endif 61.endif
63 62
64.include "../../archivers/libarchive/buildlink3.mk" 63.include "../../archivers/libarchive/buildlink3.mk"
65.include "../../mk/bsd.pkg.mk" 64.include "../../mk/bsd.pkg.mk"

cvs diff -r1.10 -r1.11 pkgsrc/pkgtools/pkgin/distinfo (switch to unified diff)

--- pkgsrc/pkgtools/pkgin/distinfo 2011/03/06 18:44:59 1.10
+++ pkgsrc/pkgtools/pkgin/distinfo 2011/08/02 21:26:59 1.11
@@ -1,5 +1,5 @@ @@ -1,5 +1,5 @@
1$NetBSD: distinfo,v 1.10 2011/03/06 18:44:59 imil Exp $ 1$NetBSD: distinfo,v 1.11 2011/08/02 21:26:59 imil Exp $
2 2
3SHA1 (pkgin-0.4.2.tar.gz) = ce383e87ad96a0b7d0cd64302f69328598476a0d 3SHA1 (pkgin-0.4.2.1.tar.gz) = f542626cd6caee810cef0aa02988b3d2d7c39772
4RMD160 (pkgin-0.4.2.tar.gz) = 95359bf1218b79e9ad18b4449b83cb36ed60d60c 4RMD160 (pkgin-0.4.2.1.tar.gz) = 66a863cdc3b4cecfc69d27cc51655df0b888c44c
5Size (pkgin-0.4.2.tar.gz) = 1340429 bytes 5Size (pkgin-0.4.2.1.tar.gz) = 1340792 bytes