Mon Mar 25 10:09:04 2013 UTC ()
USE_FEATURES must come before bsd.prefs.mk is included.


(sbd)
diff -r1.34 -r1.35 pkgsrc/pkgtools/pkgin/Makefile

cvs diff -r1.34 -r1.35 pkgsrc/pkgtools/pkgin/Makefile (expand / switch to unified diff)

--- pkgsrc/pkgtools/pkgin/Makefile 2013/02/25 19:35:38 1.34
+++ pkgsrc/pkgtools/pkgin/Makefile 2013/03/25 10:09:04 1.35
@@ -1,14 +1,14 @@ @@ -1,14 +1,14 @@
1# $NetBSD: Makefile,v 1.34 2013/02/25 19:35:38 imil Exp $ 1# $NetBSD: Makefile,v 1.35 2013/03/25 10:09:04 sbd Exp $
2# 2#
3 3
4DISTNAME= pkgin-0.6.3.1.1 4DISTNAME= pkgin-0.6.3.1.1
5CATEGORIES= pkgtools 5CATEGORIES= pkgtools
6MASTER_SITES= ftp://ftp.NetBSD.org/pub/NetBSD/misc/imil/ 6MASTER_SITES= ftp://ftp.NetBSD.org/pub/NetBSD/misc/imil/
7 7
8MAINTAINER= imil@NetBSD.org 8MAINTAINER= imil@NetBSD.org
9HOMEPAGE= http://pkgin.net/ 9HOMEPAGE= http://pkgin.net/
10COMMENT= Apt / yum like tool for managing pkgsrc binary packages 10COMMENT= Apt / yum like tool for managing pkgsrc binary packages
11LICENSE= modified-bsd 11LICENSE= modified-bsd
12 12
13EGDIR= ${PREFIX}/share/examples/${PKGBASE} 13EGDIR= ${PREFIX}/share/examples/${PKGBASE}
14CONF_FILES= ${EGDIR}/repositories.conf.example \ 14CONF_FILES= ${EGDIR}/repositories.conf.example \
@@ -19,40 +19,40 @@ INSTALLATION_DIRS+= bin ${PKGMANDIR}/man @@ -19,40 +19,40 @@ INSTALLATION_DIRS+= bin ${PKGMANDIR}/man
19 19
20WRKSRC= ${WRKDIR}/pkgin 20WRKSRC= ${WRKDIR}/pkgin
21 21
22SUBST_CLASSES+= path 22SUBST_CLASSES+= path
23SUBST_STAGE.path= pre-configure 23SUBST_STAGE.path= pre-configure
24SUBST_MESSAGE.path= Adjusting path. 24SUBST_MESSAGE.path= Adjusting path.
25SUBST_FILES.path= Makefile.in actions.c pkgin.1 25SUBST_FILES.path= Makefile.in actions.c pkgin.1
26SUBST_SED.path= -e "s|/usr/pkg/etc|${PKG_SYSCONFDIR}|g" 26SUBST_SED.path= -e "s|/usr/pkg/etc|${PKG_SYSCONFDIR}|g"
27SUBST_SED.path+= -e "s|/usr/sbin|${PKG_TOOLS_BIN}|g" 27SUBST_SED.path+= -e "s|/usr/sbin|${PKG_TOOLS_BIN}|g"
28SUBST_SED.path+= -e "s|/var|${VARBASE}|g" 28SUBST_SED.path+= -e "s|/var|${VARBASE}|g"
29SUBST_SED.path+= -e "s|/usr/pkg|${PREFIX}|g" 29SUBST_SED.path+= -e "s|/usr/pkg|${PREFIX}|g"
30SUBST_SED.path+= -e "s|!=.*uname -p|= ${MACHINE_ARCH}|g" 30SUBST_SED.path+= -e "s|!=.*uname -p|= ${MACHINE_ARCH}|g"
31 31
 32GNU_CONFIGURE= yes
 33USE_FEATURES= nbcompat
 34USE_TOOLS+= nroff
 35
32.include "../../mk/bsd.prefs.mk" 36.include "../../mk/bsd.prefs.mk"
33 37
34.if ${OPSYS} == "NetBSD" 38.if ${OPSYS} == "NetBSD"
35SUBST_CLASSES+= osrel 39SUBST_CLASSES+= osrel
36SUBST_STAGE.osrel= pre-configure 40SUBST_STAGE.osrel= pre-configure
37SUBST_MESSAGE.osrel= Adjusting repository OS release 41SUBST_MESSAGE.osrel= Adjusting repository OS release
38SUBST_FILES.osrel= REPOSITORIES 42SUBST_FILES.osrel= REPOSITORIES
39SUBST_SED.osrel= -e "s|@OSREL@|${OS_VERSION:C/_.*//}|" 43SUBST_SED.osrel= -e "s|@OSREL@|${OS_VERSION:C/_.*//}|"
40.endif 44.endif
41 45
42GNU_CONFIGURE= yes 
43USE_FEATURES= nbcompat 
44USE_TOOLS+= nroff 
45 
46MAKE_ENV+= MACHINE_ARCH=${MACHINE_ARCH} 46MAKE_ENV+= MACHINE_ARCH=${MACHINE_ARCH}
47 47
48DEPENDS+= pkg_install>=20110215:../../pkgtools/pkg_install 48DEPENDS+= pkg_install>=20110215:../../pkgtools/pkg_install
49 49
50# those have official repositories 50# those have official repositories
51.if ${OPSYS} == "NetBSD" || ${OPSYS} == "DragonFly" || ${OPSYS} == "Minix" 51.if ${OPSYS} == "NetBSD" || ${OPSYS} == "DragonFly" || ${OPSYS} == "Minix"
52pre-install: 52pre-install:
53 ${GREP} -i ${OPSYS} ${WRKSRC}/REPOSITORIES >> \ 53 ${GREP} -i ${OPSYS} ${WRKSRC}/REPOSITORIES >> \
54 ${WRKSRC}/repositories.conf 54 ${WRKSRC}/repositories.conf
55.endif 55.endif
56 56
57do-install: 57do-install:
58 ${INSTALL_PROGRAM} ${WRKSRC}/pkgin ${DESTDIR}${PREFIX}/bin 58 ${INSTALL_PROGRAM} ${WRKSRC}/pkgin ${DESTDIR}${PREFIX}/bin