Fri Mar 7 15:10:33 2014 UTC ()
Avoid the default PREFER_PKGSRC when using native X11_TYPE on Linux.


(jperkin)
diff -r1.235 -r1.236 pkgsrc/mk/defaults/mk.conf

cvs diff -r1.235 -r1.236 pkgsrc/mk/defaults/mk.conf (switch to unified diff)

--- pkgsrc/mk/defaults/mk.conf 2014/01/30 12:37:56 1.235
+++ pkgsrc/mk/defaults/mk.conf 2014/03/07 15:10:33 1.236
@@ -1,1205 +1,1208 @@ @@ -1,1205 +1,1208 @@
1# $NetBSD: mk.conf,v 1.235 2014/01/30 12:37:56 obache Exp $ 1# $NetBSD: mk.conf,v 1.236 2014/03/07 15:10:33 jperkin Exp $
2# 2#
3 3
4# This file provides default values for variables that may be overridden 4# This file provides default values for variables that may be overridden
5# in the MAKECONF file, which is /etc/mk.conf by default. 5# in the MAKECONF file, which is /etc/mk.conf by default.
6# 6#
7# Note: This file is included after the MAKECONF file, so you cannot query 7# Note: This file is included after the MAKECONF file, so you cannot query
8# these default values in the MAKECONF using the ".if" and ".for" 8# these default values in the MAKECONF using the ".if" and ".for"
9# preprocessing directives. 9# preprocessing directives.
10 10
11# ************************************************************************ 11# ************************************************************************
12# NOTE TO PEOPLE EDITING THIS FILE - USE LEADING SPACES, NOT LEADING TABS. 12# NOTE TO PEOPLE EDITING THIS FILE - USE LEADING SPACES, NOT LEADING TABS.
13# ************************************************************************ 13# ************************************************************************
14 14
15#ALLOW_VULNERABLE_PACKAGES= 15#ALLOW_VULNERABLE_PACKAGES=
16# allow the user to build packages which are known to be vulnerable to 16# allow the user to build packages which are known to be vulnerable to
17# security exploits 17# security exploits
18# Possible: defined, not defined 18# Possible: defined, not defined
19# Default: not defined 19# Default: not defined
20 20
21#AUDIT_PACKAGES_FLAGS= 21#AUDIT_PACKAGES_FLAGS=
22# List of flags passed to ``pkg_admin audit-pkg''. 22# List of flags passed to ``pkg_admin audit-pkg''.
23# 23#
24# Possible: See pkg_admin(1) 24# Possible: See pkg_admin(1)
25# Default: (no option) 25# Default: (no option)
26 26
27MANINSTALL?= maninstall catinstall 27MANINSTALL?= maninstall catinstall
28# Specify manpage installation types. 28# Specify manpage installation types.
29# Possible: maninstall, catinstall, both types or empty 29# Possible: maninstall, catinstall, both types or empty
30# Default: maninstall catinstall 30# Default: maninstall catinstall
31# FIXME: This variable is not user-settable and must be moved away from here. 31# FIXME: This variable is not user-settable and must be moved away from here.
32 32
33#MANZ= 33#MANZ=
34# gzip manual pages at installation time 34# gzip manual pages at installation time
35# Possible: defined, not defined 35# Possible: defined, not defined
36# Default: not defined 36# Default: not defined
37 37
38GZIP?= -9 38GZIP?= -9
39# default compression level when compressing files with gzip 39# default compression level when compressing files with gzip
40# Possible: -[0-9], --fast, --best (see gzip(1)) 40# Possible: -[0-9], --fast, --best (see gzip(1))
41# Default: -9 41# Default: -9
42 42
43#MAKE_JOBS= 3 43#MAKE_JOBS= 3
44# When defined, specifies the maximum number of jobs ("make -j") 44# When defined, specifies the maximum number of jobs ("make -j")
45# that are run in parallel when building packages with the default 45# that are run in parallel when building packages with the default
46# do-build action. MAKE_JOBS only affects the "build" target, 46# do-build action. MAKE_JOBS only affects the "build" target,
47# neither "test" nor "install". 47# neither "test" nor "install".
48# 48#
49# Possible values: any positive integer. Useful values are around 49# Possible values: any positive integer. Useful values are around
50# the number of processors on the machine. 50# the number of processors on the machine.
51# 51#
52# Default value: (undefined) 52# Default value: (undefined)
53# 53#
54# Warning: This is experimental. Some packages will not build with 54# Warning: This is experimental. Some packages will not build with
55# this. Disabling this for an individual package can be done by 55# this. Disabling this for an individual package can be done by
56# setting MAKE_JOBS_SAFE=NO within the per package Makefile. 56# setting MAKE_JOBS_SAFE=NO within the per package Makefile.
57 57
58#MKCRYPTO= no 58#MKCRYPTO= no
59# If not YES or yes, don't fetch, build or install crypto packages. 59# If not YES or yes, don't fetch, build or install crypto packages.
60# Possible: not defined, no 60# Possible: not defined, no
61# Default: yes 61# Default: yes
62 62
63#OBJHOSTNAME= 63#OBJHOSTNAME=
64# use hostname-specific object directories, e.g. work.amnesiac, work.localhost 64# use hostname-specific object directories, e.g. work.amnesiac, work.localhost
65# OBJHOSTNAME takes precedence over OBJMACHINE (see below). 65# OBJHOSTNAME takes precedence over OBJMACHINE (see below).
66# Possible: defined, not defined 66# Possible: defined, not defined
67# Default: not defined 67# Default: not defined
68 68
69#OBJMACHINE= 69#OBJMACHINE=
70# use machine-specific object directories, e.g. work.i386, work.sparc 70# use machine-specific object directories, e.g. work.i386, work.sparc
71# Possible: defined, not defined 71# Possible: defined, not defined
72# Default: not defined 72# Default: not defined
73 73
74.if defined(PKG_DEVELOPER) && ${PKG_DEVELOPER} != "no" 74.if defined(PKG_DEVELOPER) && ${PKG_DEVELOPER} != "no"
75PATCH_DEBUG?= 75PATCH_DEBUG?=
76.endif 76.endif
77# Used to debug patches as they are applied 77# Used to debug patches as they are applied
78# Possible: defined, not defined 78# Possible: defined, not defined
79# Default: not defined 79# Default: not defined
80 80
81PKG_COMPRESSION?= gzip 81PKG_COMPRESSION?= gzip
82# Compression algorithm for binary packages. 82# Compression algorithm for binary packages.
83# Possible: gzip, bzip2, none 83# Possible: gzip, bzip2, none
84# Default: gzip 84# Default: gzip
85# Supersedes the PKG_SUFX option and keeps the name consistent. 85# Supersedes the PKG_SUFX option and keeps the name consistent.
86 86
87PKGSRC_LOCKTYPE?= none 87PKGSRC_LOCKTYPE?= none
88# The type of locking that will be done if competing processes 88# The type of locking that will be done if competing processes
89# attempt to do work on one package directory simultaneously. 89# attempt to do work on one package directory simultaneously.
90# 90#
91# Possible values: 91# Possible values:
92# * none: No locking takes place at all. 92# * none: No locking takes place at all.
93# * once: When the lock has already been aquired by another 93# * once: When the lock has already been aquired by another
94# process, the current process is terminated. 94# process, the current process is terminated.
95# * sleep: When the lock has already been acquired by another 95# * sleep: When the lock has already been acquired by another
96# process, the current process will sleep for PKGSRC_SLEEPSECS 96# process, the current process will sleep for PKGSRC_SLEEPSECS
97# seconds and then try again. 97# seconds and then try again.
98# 98#
99# You should also set OBJHOSTNAME when you are using the same 99# You should also set OBJHOSTNAME when you are using the same
100# copy of pkgsrc on different hosts, maybe via NFS. This is because 100# copy of pkgsrc on different hosts, maybe via NFS. This is because
101# the locking process writes its process ID into the lockfile, 101# the locking process writes its process ID into the lockfile,
102# and process IDs on different hosts are unrelated. 102# and process IDs on different hosts are unrelated.
103# 103#
104# See also: LOCALBASE_LOCKTYPE, WRKDIR_LOCKTYPE. 104# See also: LOCALBASE_LOCKTYPE, WRKDIR_LOCKTYPE.
105# 105#
106# Keywords: lock locking parallel 106# Keywords: lock locking parallel
107# 107#
108 108
109PKGSRC_SLEEPSECS?= 5 109PKGSRC_SLEEPSECS?= 5
110# The number of seconds to wait when PKGSRC_LOCKTYPE is sleep. 110# The number of seconds to wait when PKGSRC_LOCKTYPE is sleep.
111# 111#
112# Possible values: any positive integer 112# Possible values: any positive integer
113# 113#
114 114
115# 115#
116# The following values are used to manage the packages collection as a whole. 116# The following values are used to manage the packages collection as a whole.
117# 117#
118 118
119#ABI= 119#ABI=
120# The Application Binary Interface (ABI) to be used, if supported by the 120# The Application Binary Interface (ABI) to be used, if supported by the
121# Operating System and/or compiler. 121# Operating System and/or compiler.
122# 122#
123# Only change this if you really know what you're doing -- libraries of 123# Only change this if you really know what you're doing -- libraries of
124# one ABI can not be linked with libraries of another! 124# one ABI can not be linked with libraries of another!
125# 125#
126# Currently only usable on IRIX or Solaris. On IRIX, it is set 126# Currently only usable on IRIX or Solaris. On IRIX, it is set
127# automatically by the bootstrap script, on Solaris, it is not. 127# automatically by the bootstrap script, on Solaris, it is not.
128# 128#
129# If you change it, be sure that _all_ the installed libraries and 129# If you change it, be sure that _all_ the installed libraries and
130# programs have the same API and use consistent compiler options. It is 130# programs have the same API and use consistent compiler options. It is
131# recommended that this variable be only changed directly after 131# recommended that this variable be only changed directly after
132# bootstrapping pkgsrc. 132# bootstrapping pkgsrc.
133# 133#
134# Possible values: 134# Possible values:
135# * 64 (64 bit ABI; both IRIX or Solaris) 135# * 64 (64 bit ABI; both IRIX or Solaris)
136# * 32 (SGI's N32 ABI; only IRIX) 136# * 32 (SGI's N32 ABI; only IRIX)
137# * undefined (SGI's old o32 ABI; only IRIX) 137# * undefined (SGI's old o32 ABI; only IRIX)
138# 138#
139# Default: undefined, but see above. 139# Default: undefined, but see above.
140 140
141#PKG_DEVELOPER= yes 141#PKG_DEVELOPER= yes
142# 142#
143# If defined and not "no" it enables some sanity checks to raise the quality 143# If defined and not "no" it enables some sanity checks to raise the quality
144# of the installed packages. See the files pkgsrc/mk/check/check-*.mk for 144# of the installed packages. See the files pkgsrc/mk/check/check-*.mk for
145# details and further configuration options. 145# details and further configuration options.
146# 146#
147# Possible: defined, not defined, no 147# Possible: defined, not defined, no
148# Default: not defined 148# Default: not defined
149 149
150USE_ABI_DEPENDS?= yes 150USE_ABI_DEPENDS?= yes
151# Honor package prerequisite ABI recommendations. If this is set 151# Honor package prerequisite ABI recommendations. If this is set
152# to "yes", all entries in ABI_DEPENDS will be added to DEPENDS. 152# to "yes", all entries in ABI_DEPENDS will be added to DEPENDS.
153# If set to "no", a warning will be printed if recommendations 153# If set to "no", a warning will be printed if recommendations
154# are possibly ignored. 154# are possibly ignored.
155# 155#
156# WARNING: This should only be changed if you know what you're doing. 156# WARNING: This should only be changed if you know what you're doing.
157# Please read pkgsrc/doc/pkgsrc.txt for details. 157# Please read pkgsrc/doc/pkgsrc.txt for details.
158# 158#
159# Possible: yes, no 159# Possible: yes, no
160# Default: yes 160# Default: yes
161 161
162#PKG_REGISTER_SHELLS= YES 162#PKG_REGISTER_SHELLS= YES
163# Automatically register shells in /etc/shells 163# Automatically register shells in /etc/shells
164# Possible: YES, NO 164# Possible: YES, NO
165# Default: YES 165# Default: YES
166 166
167PKGSRC_COMPILER?= gcc 167PKGSRC_COMPILER?= gcc
168# Compiler type(s) to use for building packages 168# Compiler type(s) to use for building packages
169# Possible: (see comments in mk/compiler.mk) 169# Possible: (see comments in mk/compiler.mk)
170# Default: "gcc" 170# Default: "gcc"
171 171
172PKGSRC_MESSAGE_RECIPIENTS?= 172PKGSRC_MESSAGE_RECIPIENTS?=
173# login names of recipients of any MESSAGE files which will be mailed 173# login names of recipients of any MESSAGE files which will be mailed
174# Possible: any login names 174# Possible: any login names
175# Default: none 175# Default: none
176 176
177PKGSRC_SHOW_BUILD_DEFS?=yes 177PKGSRC_SHOW_BUILD_DEFS?=yes
178# Show BUILD_DEFS definitions for a package when it is being built 178# Show BUILD_DEFS definitions for a package when it is being built
179# (BUILD_DEFS are extra definitions which govern how some packages are 179# (BUILD_DEFS are extra definitions which govern how some packages are
180# built and behave) 180# built and behave)
181# Possible: "yes", not "yes" 181# Possible: "yes", not "yes"
182# Default: "yes" 182# Default: "yes"
183 183
184PKGSRC_RUN_TEST?= no 184PKGSRC_RUN_TEST?= no
185# 185#
186# Many packages bring their own self tests to ensure they basically 186# Many packages bring their own self tests to ensure they basically
187# work. To run these tests after building a package, set this variable 187# work. To run these tests after building a package, set this variable
188# to "yes". 188# to "yes".
189# 189#
190# Note: Some packages make heavy use of the random number generator in 190# Note: Some packages make heavy use of the random number generator in
191# their tests, so need to make sure that there are always enough random 191# their tests, so need to make sure that there are always enough random
192# numbers on your machine. The package security/bitstir may help here. 192# numbers on your machine. The package security/bitstir may help here.
193# 193#
194# Possible: yes, no 194# Possible: yes, no
195# Default: no 195# Default: no
196 196
197.if (!empty(MACHINE_PLATFORM:MNetBSD-*-*) && \ 197.if (!empty(MACHINE_PLATFORM:MNetBSD-*-*) && \
198 exists(/usr/X11R7/lib/libX11.so)) 198 exists(/usr/X11R7/lib/libX11.so))
199PREFER_PKGSRC?= 199PREFER_PKGSRC?=
200.elif (!empty(MACHINE_PLATFORM:MNetBSD-*-*) && \ 200.elif (!empty(MACHINE_PLATFORM:MNetBSD-*-*) && \
201 exists(/usr/lib/libexpat.so)) 201 exists(/usr/lib/libexpat.so))
202PREFER_PKGSRC?= MesaLib Xft2 Xrandr Xrender fontconfig \ 202PREFER_PKGSRC?= MesaLib Xft2 Xrandr Xrender fontconfig \
203 freetype2 glu randrproto renderproto xcursor 203 freetype2 glu randrproto renderproto xcursor
204.elif (!empty(MACHINE_PLATFORM:MOpenBSD-*-*) && \ 204.elif (!empty(MACHINE_PLATFORM:MOpenBSD-*-*) && \
205 exists(/usr/X11R6/lib/X11/config/xorgversion.def)) 205 exists(/usr/X11R6/lib/X11/config/xorgversion.def))
206PREFER_PKGSRC?= 206PREFER_PKGSRC?=
 207.elif !empty(MACHINE_PLATFORM:MLinux-*-*) && \
 208 (!defined(X11_TYPE) || ${X11_TYPE} == "native")
 209PREFER_PKGSRC?=
207.elif !empty(MACHINE_PLATFORM:MDarwin-??.*-*) && \ 210.elif !empty(MACHINE_PLATFORM:MDarwin-??.*-*) && \
208 (!defined(X11_TYPE) || ${X11_TYPE} == "native") 211 (!defined(X11_TYPE) || ${X11_TYPE} == "native")
209PREFER_PKGSRC?= 212PREFER_PKGSRC?=
210.elif !empty(MACHINE_PLATFORM:MDarwin-9.*-*) && \ 213.elif !empty(MACHINE_PLATFORM:MDarwin-9.*-*) && \
211 (!defined(X11_TYPE) || ${X11_TYPE} == "native") 214 (!defined(X11_TYPE) || ${X11_TYPE} == "native")
212PREFER_PKGSRC?= fontconfig pixman Xft2 215PREFER_PKGSRC?= fontconfig pixman Xft2
213.elif !empty(MACHINE_PLATFORM:MCygwin-*-*) && \ 216.elif !empty(MACHINE_PLATFORM:MCygwin-*-*) && \
214 exists(/usr/lib/X11/config/xorgversion.def) 217 exists(/usr/lib/X11/config/xorgversion.def)
215PREFER_PKGSRC?= 218PREFER_PKGSRC?=
216.else 219.else
217PREFER_PKGSRC?= MesaLib Xft2 Xrandr Xrender expat fontconfig \ 220PREFER_PKGSRC?= MesaLib Xft2 Xrandr Xrender expat fontconfig \
218 freetype2 glu randrproto renderproto xcursor 221 freetype2 glu randrproto renderproto xcursor
219.endif 222.endif
220PREFER_NATIVE?= yes 223PREFER_NATIVE?= yes
221# 224#
222# When building packages, whether to prefer the pkgsrc or native 225# When building packages, whether to prefer the pkgsrc or native
223# versions of software that's also part of the base system. Its value 226# versions of software that's also part of the base system. Its value
224# can be either yes/no, or a list of packages as named in the 227# can be either yes/no, or a list of packages as named in the
225# BUILDLINK_TREE line in a package's buildlink3.mk file. 228# BUILDLINK_TREE line in a package's buildlink3.mk file.
226# Preferences are determined by the most specific instance of the 229# Preferences are determined by the most specific instance of the
227# package in either PREFER_PKGSRC or PREFER_NATIVE. If a package is 230# package in either PREFER_PKGSRC or PREFER_NATIVE. If a package is
228# specified in neither or in both variables, then PREFER_PKGSRC has 231# specified in neither or in both variables, then PREFER_PKGSRC has
229# precedence over PREFER_NATIVE. 232# precedence over PREFER_NATIVE.
230# 233#
231# Possible: yes, no, or a list of packages 234# Possible: yes, no, or a list of packages
232 235
233PREFER_NATIVE_PTHREADS?= yes 236PREFER_NATIVE_PTHREADS?= yes
234# This toggles whether we prefer using the native pthreads implementation 237# This toggles whether we prefer using the native pthreads implementation
235# or the pkgsrc OPR (see pthread.buildlink3.mk). This setting is 238# or the pkgsrc OPR (see pthread.buildlink3.mk). This setting is
236# independent of the PREFER_* variables named above. 239# independent of the PREFER_* variables named above.
237 240
238#WRKOBJDIR= /usr/tmp 241#WRKOBJDIR= /usr/tmp
239# build here instead of in pkgsrc 242# build here instead of in pkgsrc
240# Possible: any path 243# Possible: any path
241# Default: not defined 244# Default: not defined
242# 245#
243# Keywords: work tmp 246# Keywords: work tmp
244 247
245LOCALBASE?= /usr/pkg 248LOCALBASE?= /usr/pkg
246# This is the base directory where all packages will be installed. 249# This is the base directory where all packages will be installed.
247# 250#
248# Possible values: Any absolute path that does not contain special 251# Possible values: Any absolute path that does not contain special
249# characters. 252# characters.
250# 253#
251# See also: PREFIX, VARBASE 254# See also: PREFIX, VARBASE
252# 255#
253 256
254CROSSBASE?= ${LOCALBASE}/cross 257CROSSBASE?= ${LOCALBASE}/cross
255# Where "cross" category packages install 258# Where "cross" category packages install
256# Possible: any path 259# Possible: any path
257# Default: ${LOCALBASE}/cross 260# Default: ${LOCALBASE}/cross
258 261
259VARBASE?= /var 262VARBASE?= /var
260# Where files containing local state information are installed 263# Where files containing local state information are installed
261# Possible: any path 264# Possible: any path
262# Default: /var 265# Default: /var
263 266
264#X11_TYPE?= native 267#X11_TYPE?= native
265# Used to set the X11 implementation used to build X11 packages. 268# Used to set the X11 implementation used to build X11 packages.
266# Possible: modular (uses x11/libX11 and friends), or 269# Possible: modular (uses x11/libX11 and friends), or
267# native (uses pkgtools/x11-links to use the native, non-pkgsrc-managed X11). 270# native (uses pkgtools/x11-links to use the native, non-pkgsrc-managed X11).
268# Default: native 271# Default: native
269# The default is defined in bsd.prefs.mk to allow platform specific overrides. 272# The default is defined in bsd.prefs.mk to allow platform specific overrides.
270 273
271#X11BASE?= /usr/X11R7 274#X11BASE?= /usr/X11R7
272# Where X11 is installed on the system. 275# Where X11 is installed on the system.
273# (and the default install path of X11 pkgs) 276# (and the default install path of X11 pkgs)
274# Possible: any path 277# Possible: any path
275# Default: /usr/X11R7, /usr/openwin for Solaris 278# Default: /usr/X11R7, /usr/openwin for Solaris
276 279
277#MOTIFBASE?= /usr/X11R7 280#MOTIFBASE?= /usr/X11R7
278# Where Motif-2.0-compatible headers and libraries are installed 281# Where Motif-2.0-compatible headers and libraries are installed
279# on the system. 282# on the system.
280# Possible: any path 283# Possible: any path
281# Default: ${X11PREFIX} or where motif, openmotif or lesstif is installed 284# Default: ${X11PREFIX} or where motif, openmotif or lesstif is installed
282 285
283PKGINFODIR?= info 286PKGINFODIR?= info
284# The subdirectory of PREFIX that holds the GNU info files and the 287# The subdirectory of PREFIX that holds the GNU info files and the
285# directory index file ("dir"). Using a value different from the 288# directory index file ("dir"). Using a value different from the
286# default can be useful when LOCALBASE=/usr. 289# default can be useful when LOCALBASE=/usr.
287# 290#
288# Possible: A sane pathname. 291# Possible: A sane pathname.
289# 292#
290# Examples: 293# Examples:
291# * share/info 294# * share/info
292# 295#
293# Note: the support for custom setting (not "info") is not complete. 296# Note: the support for custom setting (not "info") is not complete.
294# 297#
295# See also: PKGMANDIR 298# See also: PKGMANDIR
296 299
297PKGMANDIR?= man 300PKGMANDIR?= man
298# The subdirectory of PREFIX that holds the manual pages and their 301# The subdirectory of PREFIX that holds the manual pages and their
299# subdirectories (e.g. man1, man7). Using a value different from the 302# subdirectories (e.g. man1, man7). Using a value different from the
300# default can be useful when LOCALBASE=/usr. 303# default can be useful when LOCALBASE=/usr.
301# 304#
302# Possible: Any sane pathname. 305# Possible: Any sane pathname.
303# 306#
304# Examples: 307# Examples:
305# * share/man 308# * share/man
306# 309#
307# Note: the support for custom setting (not "man") is not complete. 310# Note: the support for custom setting (not "man") is not complete.
308# 311#
309# See also: PKGINFODIR 312# See also: PKGINFODIR
310 313
311PKGGNUDIR?= gnu/ 314PKGGNUDIR?= gnu/
312# The subdirectory of PREFIX that holds gnu programs and manual pages. 315# The subdirectory of PREFIX that holds gnu programs and manual pages.
313# Making this value empty can be useful when trying to build a fully 316# Making this value empty can be useful when trying to build a fully
314# GNU environment. 317# GNU environment.
315# 318#
316# Possible: Any sane pathname including a trailing slash, or empty to 319# Possible: Any sane pathname including a trailing slash, or empty to
317# install into LOCALBASE 320# install into LOCALBASE
318 321
319BSDSRCDIR?= /usr/src 322BSDSRCDIR?= /usr/src
320# Where the NetBSD src module source tree is located 323# Where the NetBSD src module source tree is located
321# currently only used by package support scripts for packages that 324# currently only used by package support scripts for packages that
322# include their source to find their upstream source 325# include their source to find their upstream source
323# 326#
324# Possible: any path 327# Possible: any path
325# Default: /usr/src 328# Default: /usr/src
326 329
327BSDXSRCDIR?= /usr/xsrc 330BSDXSRCDIR?= /usr/xsrc
328# Where the NetBSD xsrc module source tree is located 331# Where the NetBSD xsrc module source tree is located
329# used in the x11/xservers package 332# used in the x11/xservers package
330# Possible: any path 333# Possible: any path
331# Default: /usr/xsrc 334# Default: /usr/xsrc
332 335
333DISTDIR?= ${PKGSRCDIR}/distfiles 336DISTDIR?= ${PKGSRCDIR}/distfiles
334# Directory where original distribution 337# Directory where original distribution
335# files are stored. 338# files are stored.
336# Possible: any path you like 339# Possible: any path you like
337# Default: /usr/pkgsrc/distfiles 340# Default: /usr/pkgsrc/distfiles
338 341
339#DIST_PATH= /cdrom/0/distfiles:${HOME}/distfiles 342#DIST_PATH= /cdrom/0/distfiles:${HOME}/distfiles
340# Colon-delimited list of directories in which to search for 343# Colon-delimited list of directories in which to search for
341# ${DISTFILES} and ${PATCHFILES}. If the requested file is not in any 344# ${DISTFILES} and ${PATCHFILES}. If the requested file is not in any
342# of the directories in ${DIST_PATH}, it will be downloaded into 345# of the directories in ${DIST_PATH}, it will be downloaded into
343# ${DISTDIR}. If the requested file is in one of the directories in 346# ${DISTDIR}. If the requested file is in one of the directories in
344# ${DIST_PATH}, a symbolic link will be made to it from ${DISTDIR}. 347# ${DIST_PATH}, a symbolic link will be made to it from ${DISTDIR}.
345# ${DIST_PATH} directories will will be searched before ${DISTDIR}, 348# ${DIST_PATH} directories will will be searched before ${DISTDIR},
346# letting a CD hold the main distfiles archive, and local ${DISTDIR} 349# letting a CD hold the main distfiles archive, and local ${DISTDIR}
347# hold any updated distfiles, for example. 350# hold any updated distfiles, for example.
348# Possible: any directories 351# Possible: any directories
349# Default: none 352# Default: none
350 353
351DEFAULT_VIEW?= "" 354DEFAULT_VIEW?= ""
352# This is the default view to which packages are added after installation. 355# This is the default view to which packages are added after installation.
353# Default: "" (the empty view) 356# Default: "" (the empty view)
354 357
355FETCH_USING?= auto 358FETCH_USING?= auto
356# The program type to fetch files. 359# The program type to fetch files.
357# "manual" will explicitly fail if the DISTFILES don't exist locally. 360# "manual" will explicitly fail if the DISTFILES don't exist locally.
358# "custom" requires setting FETCH_CMD, FETCH_BEFORE_ARGS, FETCH_AFTER_ARGS, 361# "custom" requires setting FETCH_CMD, FETCH_BEFORE_ARGS, FETCH_AFTER_ARGS,
359# FETCH_RESUME_ARGS and FETCH_OUTPUT_ARGS. 362# FETCH_RESUME_ARGS and FETCH_OUTPUT_ARGS.
360# 363#
361# The default value can be overriden by a package before including 364# The default value can be overriden by a package before including
362# bsd.prefs.mk and by the user in mk.conf. 365# bsd.prefs.mk and by the user in mk.conf.
363# Possible: auto, curl, custom, fetch, ftp, manual, wget 366# Possible: auto, curl, custom, fetch, ftp, manual, wget
364 367
365#FIX_SYSTEM_HEADERS= 368#FIX_SYSTEM_HEADERS=
366# Make pkgtools/posix_headers an automatic build dependency for all  369# Make pkgtools/posix_headers an automatic build dependency for all
367# packages except those in the pkgtools category. 370# packages except those in the pkgtools category.
368# Possible: "yes", not defined 371# Possible: "yes", not defined
369# Default: not defined 372# Default: not defined
370 373
371LIBTOOLIZE_PLIST?= yes 374LIBTOOLIZE_PLIST?= yes
372# This determines whether to expand libtool archives (.la files) in PLISTs 375# This determines whether to expand libtool archives (.la files) in PLISTs
373# into the represented library names. 376# into the represented library names.
374# Possible: yes, no 377# Possible: yes, no
375# Default: yes 378# Default: yes
376 379
377PKG_INSTALLATION_PREFS?= overwrite pkgviews 380PKG_INSTALLATION_PREFS?= overwrite pkgviews
378# This is a whitespace-separated list of installation types to try when 381# This is a whitespace-separated list of installation types to try when
379# building a package, in order of preference. 382# building a package, in order of preference.
380# Possible: any of: overwrite, pkgviews 383# Possible: any of: overwrite, pkgviews
381# Default: overwrite pkgviews 384# Default: overwrite pkgviews
382 385
383PKG_RESUME_TRANSFERS?= NO 386PKG_RESUME_TRANSFERS?= NO
384# Used in pkgsrc to resume transfers, if enabled the whole file won't be 387# Used in pkgsrc to resume transfers, if enabled the whole file won't be
385# downloaded from scratch again. 388# downloaded from scratch again.
386# Possible: yes or no. 389# Possible: yes or no.
387# Default: no. 390# Default: no.
388 391
389PKG_SYSCONFBASE?= ${PREFIX}/etc 392PKG_SYSCONFBASE?= ${PREFIX}/etc
390# This is the main config directory under which all package configuration 393# This is the main config directory under which all package configuration
391# files should be found. 394# files should be found.
392# Possible: any path you like 395# Possible: any path you like
393# Default: ${PREFIX}/etc 396# Default: ${PREFIX}/etc
394 397
395RCD_SCRIPTS_DIR?= /etc/rc.d 398RCD_SCRIPTS_DIR?= /etc/rc.d
396# This is the system rc.d script directory in which all rc.d scripts 399# This is the system rc.d script directory in which all rc.d scripts
397# expected to be executed at boot-time should be found. Package views 400# expected to be executed at boot-time should be found. Package views
398# users may want to set this to "${PKG_SYSCONFBASEDIR}/rc.d". 401# users may want to set this to "${PKG_SYSCONFBASEDIR}/rc.d".
399# Possible: any path you like 402# Possible: any path you like
400# Default: /etc/rc.d 403# Default: /etc/rc.d
401 404
402PACKAGES?= ${PKGSRCDIR}/packages 405PACKAGES?= ${PKGSRCDIR}/packages
403# Stores generated packages 406# Stores generated packages
404# Possible: any path you like 407# Possible: any path you like
405# Default: /usr/pkgsrc/packages 408# Default: /usr/pkgsrc/packages
406 409
407#PASSIVE_FETCH= 410#PASSIVE_FETCH=
408# Use ftp(1) in passive mode, for use behind filtering firewalls. 411# Use ftp(1) in passive mode, for use behind filtering firewalls.
409# (Set by default in ftp(1).) 412# (Set by default in ftp(1).)
410# Possible: defined, not defined 413# Possible: defined, not defined
411# Default: not defined 414# Default: not defined
412 415
413PATCH_FUZZ_FACTOR?= -F0 416PATCH_FUZZ_FACTOR?= -F0
414# Fuzz factor to use when applying patches. Will only be applied when 417# Fuzz factor to use when applying patches. Will only be applied when
415# using a patch(1) that understands -F. This should be a "?=" 418# using a patch(1) that understands -F. This should be a "?="
416# setting, since package Makefiles may set this value, before 419# setting, since package Makefiles may set this value, before
417# /etc/mk.conf is read. 420# /etc/mk.conf is read.
418# Possible: "-Fn" where n is a number, none 421# Possible: "-Fn" where n is a number, none
419# Default: "-F0" 422# Default: "-F0"
420 423
421#ACCEPTABLE_LICENSES= fee-based-commercial-use no-commercial-use \ 424#ACCEPTABLE_LICENSES= fee-based-commercial-use no-commercial-use \
422# no-profit limited-redistribution 425# no-profit limited-redistribution
423# Whitespace-delimited list of the types of license which are 426# Whitespace-delimited list of the types of license which are
424# acceptable for installation. Packages for which you need 427# acceptable for installation. Packages for which you need
425# to accept a license will display a message like the following: 428# to accept a license will display a message like the following:
426# ===> xv-3.10anb9 has an unacceptable license: xv-license. 429# ===> xv-3.10anb9 has an unacceptable license: xv-license.
427# ===> To view the license, enter "/usr/bin/make show-license". 430# ===> To view the license, enter "/usr/bin/make show-license".
428# ===> To indicate acceptance, add this line to your /etc/mk.conf: 431# ===> To indicate acceptance, add this line to your /etc/mk.conf:
429# ===> ACCEPTABLE_LICENSES+=xv-license 432# ===> ACCEPTABLE_LICENSES+=xv-license
430# 433#
431# Default: none 434# Default: none
432 435
433#SPECIFIC_PKGS= yes 436#SPECIFIC_PKGS= yes
434# 437#
435# When doing a bulk build, don't build all packages, only those listed 438# When doing a bulk build, don't build all packages, only those listed
436# in SITE_SPECIFIC_PKGS, HOST_SPECIFIC_PKGS, GROUP_SPECIFIC_PKGS, and 439# in SITE_SPECIFIC_PKGS, HOST_SPECIFIC_PKGS, GROUP_SPECIFIC_PKGS, and
437# USER_SPECIFIC_PKGS. 440# USER_SPECIFIC_PKGS.
438# 441#
439# Possible: defined, not defined 442# Possible: defined, not defined
440# Default: not defined 443# Default: not defined
441 444
442#SITE_SPECIFIC_PKGS= 445#SITE_SPECIFIC_PKGS=
443# List of packages that are wanted for each host on the site. Each 446# List of packages that are wanted for each host on the site. Each
444# package in the list is of the form <category>/<package>. 447# package in the list is of the form <category>/<package>.
445# Possible: any combination of packages 448# Possible: any combination of packages
446# Default: not set 449# Default: not set
447 450
448#HOST_SPECIFIC_PKGS= 451#HOST_SPECIFIC_PKGS=
449# List of packages that are wanted for this particular host/machine. 452# List of packages that are wanted for this particular host/machine.
450# Each package in the list is of the form <category>/<package>. 453# Each package in the list is of the form <category>/<package>.
451# Possible: any combination of packages 454# Possible: any combination of packages
452# Default: not set 455# Default: not set
453 456
454#GROUP_SPECIFIC_PKGS= 457#GROUP_SPECIFIC_PKGS=
455# List of packages that are wanted for this group of users. Each 458# List of packages that are wanted for this group of users. Each
456# package in the list is of the form <category>/<package>. 459# package in the list is of the form <category>/<package>.
457# Possible: any combination of packages 460# Possible: any combination of packages
458# Default: not set 461# Default: not set
459 462
460#USER_SPECIFIC_PKGS= 463#USER_SPECIFIC_PKGS=
461# List of packages that are wanted for this particular user. Each 464# List of packages that are wanted for this particular user. Each
462# package in the list is of the form <category>/<package>. 465# package in the list is of the form <category>/<package>.
463# Possible: any combination of packages 466# Possible: any combination of packages
464# Default: not set 467# Default: not set
465 468
466EXTRACT_USING?= nbtar 469EXTRACT_USING?= nbtar
467# Use the specified tool to extract tar/ustar archives. 470# Use the specified tool to extract tar/ustar archives.
468# Possible: gtar, nbtar, pax 471# Possible: gtar, nbtar, pax
469# Default: nbtar 472# Default: nbtar
470 473
471#FAILOVER_FETCH= 474#FAILOVER_FETCH=
472# Perform a checksum at "make fetch" time. If the checksum doesn't 475# Perform a checksum at "make fetch" time. If the checksum doesn't
473# match the stored value, try to retrieve the file from the next site 476# match the stored value, try to retrieve the file from the next site
474# in the list 477# in the list
475# Possible: defined, not defined 478# Possible: defined, not defined
476# Default: not defined 479# Default: not defined
477 480
478#MASTER_SORT= .ac.at .at .de .ch .se .fi .no 481#MASTER_SORT= .ac.at .at .de .ch .se .fi .no
479# Whitespace delimited list of preferred download locations. 482# Whitespace delimited list of preferred download locations.
480# MASTER_SITES and PATCH_SITES will be reordered according to the hosts' 483# MASTER_SITES and PATCH_SITES will be reordered according to the hosts'
481# address last components. 484# address last components.
482# Possible: list of domain name suffixes 485# Possible: list of domain name suffixes
483# Default: none 486# Default: none
484 487
485#MASTER_SORT_REGEX= ftp://.*/ 488#MASTER_SORT_REGEX= ftp://.*/
486# Same as MASTER_SORT, but takes a regular expression for more 489# Same as MASTER_SORT, but takes a regular expression for more
487# flexibility in matching. Regexps defined here have higher priority 490# flexibility in matching. Regexps defined here have higher priority
488# than MASTER_SORT. This example would prefer ftp transfers over 491# than MASTER_SORT. This example would prefer ftp transfers over
489# anything else. 492# anything else.
490# Possible: Regexps as in awk(1) 493# Possible: Regexps as in awk(1)
491# Default: none 494# Default: none
492 495
493.if defined(PKG_DEVELOPER) && ${PKG_DEVELOPER} != "no" 496.if defined(PKG_DEVELOPER) && ${PKG_DEVELOPER} != "no"
494MASTER_SORT_RANDOM?= NO 497MASTER_SORT_RANDOM?= NO
495.else 498.else
496MASTER_SORT_RANDOM?= YES 499MASTER_SORT_RANDOM?= YES
497.endif 500.endif
498# If set to YES or yes, a list of master sites will be randomly intermixed. 501# If set to YES or yes, a list of master sites will be randomly intermixed.
499# Also, both MASTER_SORT and MASTER_SORT_REGEX may be applied later. 502# Also, both MASTER_SORT and MASTER_SORT_REGEX may be applied later.
500# Possible: yes, no / not defined 503# Possible: yes, no / not defined
501# Default: NO if PKG_DEVELOPER is enabled, YES otherwise 504# Default: NO if PKG_DEVELOPER is enabled, YES otherwise
502 505
503#PATCH_DEBUG= 506#PATCH_DEBUG=
504# Used to debug patches as they are applied 507# Used to debug patches as they are applied
505# Possible: defined, not defined 508# Possible: defined, not defined
506# Default: not defined 509# Default: not defined
507 510
508#PKG_FC= 511#PKG_FC=
509# The Fortran compiler used to compile Fortran code contained in 512# The Fortran compiler used to compile Fortran code contained in
510# packages. 513# packages.
511# Possible: any Fortran compiler 514# Possible: any Fortran compiler
512# Default: none 515# Default: none
513 516
514#IMAKEOPTS= 517#IMAKEOPTS=
515# Options passed to imake(1). The defaults ensure that imake finds the 518# Options passed to imake(1). The defaults ensure that imake finds the
516# correct commands. 519# correct commands.
517# Possible: any valid flags 520# Possible: any valid flags
518# Default: 521# Default:
519# for Solaris with gcc: 522# for Solaris with gcc:
520# -DHasGcc2=YES -DHasGcc2ForCplusplus=YES 523# -DHasGcc2=YES -DHasGcc2ForCplusplus=YES
521# for IRIX: 524# for IRIX:
522# -DMakeCmd=${PREFIX}/bin/bmake -DProjectRoot=${X11BASE} \ 525# -DMakeCmd=${PREFIX}/bin/bmake -DProjectRoot=${X11BASE} \
523# -DManUsr=${PREFIX} 526# -DManUsr=${PREFIX}
524.if ${OPSYS} == "IRIX" 527.if ${OPSYS} == "IRIX"
525#IMAKEOPTS?= -DMakeCmd=${PREFIX}/bin/bmake -DProjectRoot=${X11BASE} \ 528#IMAKEOPTS?= -DMakeCmd=${PREFIX}/bin/bmake -DProjectRoot=${X11BASE} \
526# -DManUsr=${PREFIX} 529# -DManUsr=${PREFIX}
527# ABI specific flags may be added during bootstrapping process or by hand: 530# ABI specific flags may be added during bootstrapping process or by hand:
528. if defined(ABI) 531. if defined(ABI)
529. if ${ABI} == "32" 532. if ${ABI} == "32"
530#IMAKEOPTS+= -DBuildN32 533#IMAKEOPTS+= -DBuildN32
531. else 534. else
532#IMAKEOPTS+= -DBuild64bit 535#IMAKEOPTS+= -DBuild64bit
533. endif 536. endif
534. endif 537. endif
535# you may also wish to add ISA specific flags, such as "-DSgiISA32=4" if 538# you may also wish to add ISA specific flags, such as "-DSgiISA32=4" if
536# you are compiling for mips4. 539# you are compiling for mips4.
537.elif ${OPSYS} == "SunOS" 540.elif ${OPSYS} == "SunOS"
538# The flags required by imake with gcc on Solaris are automatically 541# The flags required by imake with gcc on Solaris are automatically
539# added if gcc is being used. Though it should not be needed, you can 542# added if gcc is being used. Though it should not be needed, you can
540# override this using: 543# override this using:
541#IMAKEOPTS+= -DHasGcc2=YES -DHasGcc2ForCplusplus=YES 544#IMAKEOPTS+= -DHasGcc2=YES -DHasGcc2ForCplusplus=YES
542.endif 545.endif
543 546
544PRE_ROOT_CMD?= ${TRUE} 547PRE_ROOT_CMD?= ${TRUE}
545# Command to be run by normal user, just before becoming root (see 548# Command to be run by normal user, just before becoming root (see
546# SU_CMD) to install the package. For example, "chmod -R o+w ${WRKDIR}" 549# SU_CMD) to install the package. For example, "chmod -R o+w ${WRKDIR}"
547# would allow others to write and modify files below ${WRKDIR}. 550# would allow others to write and modify files below ${WRKDIR}.
548# Possible: any shell commands 551# Possible: any shell commands
549# Default: none 552# Default: none
550 553
551SU_CMD?= ${ROOT_CMD} 554SU_CMD?= ${ROOT_CMD}
552# Command to perform before "make install", if the user does not have 555# Command to perform before "make install", if the user does not have
553# an effective uid of 0. A possible substitute is "sudo sh -c" 556# an effective uid of 0. A possible substitute is "sudo sh -c"
554# Possible: su, sudo, or priv, with appropriate arguments 557# Possible: su, sudo, or priv, with appropriate arguments
555# Default: dependent on operating system. For NetBSD: ${SU} - root -c 558# Default: dependent on operating system. For NetBSD: ${SU} - root -c
556 559
557SU_CMD_PATH_APPEND?=/sbin:/usr/sbin 560SU_CMD_PATH_APPEND?=/sbin:/usr/sbin
558# Additional directories (in a colon separated list) to be added to the 561# Additional directories (in a colon separated list) to be added to the
559# PATH environment variable when running ${SU_CMD}. 562# PATH environment variable when running ${SU_CMD}.
560# Default: /sbin:/usr/sbin 563# Default: /sbin:/usr/sbin
561 564
562FATAL_OBJECT_FMT_SKEW?=yes 565FATAL_OBJECT_FMT_SKEW?=yes
563# If there is a pre-requisite package, which has a different object format 566# If there is a pre-requisite package, which has a different object format
564# from that currently being used, halt execution. One (rare) situation where 567# from that currently being used, halt execution. One (rare) situation where
565# it is possible for the difference to be harmless is where the pre-requisite 568# it is possible for the difference to be harmless is where the pre-requisite
566# package provides an executable, not a library. 569# package provides an executable, not a library.
567# Possible: yes, no 570# Possible: yes, no
568# Default: yes 571# Default: yes
569 572
570WARN_NO_OBJECT_FMT?=yes 573WARN_NO_OBJECT_FMT?=yes
571# Packages installed on a machine before OBJECT_FMT was added to the 574# Packages installed on a machine before OBJECT_FMT was added to the
572# BUILD_DEFS definitions (on 29th September 1999) cannot say which 575# BUILD_DEFS definitions (on 29th September 1999) cannot say which
573# object format they are in. This will cause a warning to be displayed. 576# object format they are in. This will cause a warning to be displayed.
574# Set this to "no" to stop the warning message being shown. 577# Set this to "no" to stop the warning message being shown.
575# Possible: yes, no 578# Possible: yes, no
576# Default: yes 579# Default: yes
577 580
578#SMART_MESSAGES=yes 581#SMART_MESSAGES=yes
579# Display the make(1) target, and the current stack of packages being built, 582# Display the make(1) target, and the current stack of packages being built,
580# when displaying messages during package builds. 583# when displaying messages during package builds.
581# Possible: defined, not defined 584# Possible: defined, not defined
582# Default: not defined 585# Default: not defined
583 586
584#BINPKG_SITES=... 587#BINPKG_SITES=...
585# Whitespace separated list of URLs for binary packages. Directories 588# Whitespace separated list of URLs for binary packages. Directories
586# "All" etc. are expected in the named place, variables "rel" and 589# "All" etc. are expected in the named place, variables "rel" and
587# "arch" are replaced with OS release ("1.5", ...) and architecture 590# "arch" are replaced with OS release ("1.5", ...) and architecture
588# ("mipsel", ...) 591# ("mipsel", ...)
589# Possible: any ftp url, see above. 592# Possible: any ftp url, see above.
590# Default: ftp://ftp.NetBSD.org/pub/pkgsrc/packages/NetBSD/$${rel}/$${arch} 593# Default: ftp://ftp.NetBSD.org/pub/pkgsrc/packages/NetBSD/$${rel}/$${arch}
591 594
592#BIN_INSTALL_FLAGS= 595#BIN_INSTALL_FLAGS=
593# List of flags passed to pkg_add(8) in the bin_install package. 596# List of flags passed to pkg_add(8) in the bin_install package.
594# Possible: -v, -u, etc. See pkg_add(8) 597# Possible: -v, -u, etc. See pkg_add(8)
595# Default: (no option) 598# Default: (no option)
596 599
597#LOCALPATCHES=... 600#LOCALPATCHES=...
598# Directory where local patches are stored. See pkgsrc/doc/pkgsrc.txt. 601# Directory where local patches are stored. See pkgsrc/doc/pkgsrc.txt.
599# Possible: Any local directory 602# Possible: Any local directory
600# Default: none 603# Default: none
601 604
602# 605#
603# Definitions used only in the packages collection 606# Definitions used only in the packages collection
604# 607#
605 608
606#ACROREAD_FONTPATH?= ${PREFIX}/lib/X11/fonts/TTF 609#ACROREAD_FONTPATH?= ${PREFIX}/lib/X11/fonts/TTF
607# Colon separated list of additional directories for acroread7 to 610# Colon separated list of additional directories for acroread7 to
608# look in for TTF/Type1 fonts. 611# look in for TTF/Type1 fonts.
609# Default: ${PREFIX}/lib/X11/fonts/TTF 612# Default: ${PREFIX}/lib/X11/fonts/TTF
610 613
611AMANDA_USER?= amandabackup 614AMANDA_USER?= amandabackup
612# Used in the amanda packages to specify the login user and group 615# Used in the amanda packages to specify the login user and group
613# responsible for backups. 616# responsible for backups.
614# Possible: any user name 617# Possible: any user name
615# Default: backup 618# Default: backup
616 619
617AMANDA_TMP?= /tmp/amanda 620AMANDA_TMP?= /tmp/amanda
618# Specifies the directory in which amanda puts its debug and temporary 621# Specifies the directory in which amanda puts its debug and temporary
619# files. 622# files.
620# Default: /tmp/amanda 623# Default: /tmp/amanda
621 624
622AMANDA_VAR?= ${VARBASE}/amanda 625AMANDA_VAR?= ${VARBASE}/amanda
623# Specifies the directory in which amanda puts its logs and status 626# Specifies the directory in which amanda puts its logs and status
624# files. 627# files.
625# Default: ${VARBASE}/amanda 628# Default: ${VARBASE}/amanda
626 629
627#APACHE_CUSTOM_CFLAGS= 630#APACHE_CUSTOM_CFLAGS=
628# Used in apache to pass extra CFLAGS to the compiler during 631# Used in apache to pass extra CFLAGS to the compiler during
629# the build. 632# the build.
630# Possible: any legal compiler flags, e.g. -O6 -DHARD_SERVER_LIMIT=512 633# Possible: any legal compiler flags, e.g. -O6 -DHARD_SERVER_LIMIT=512
631# Default: not defined 634# Default: not defined
632 635
633APACHE_USER?= www 636APACHE_USER?= www
634# Used in apache, apache2, isap, and smb2www to specify the user 637# Used in apache, apache2, isap, and smb2www to specify the user
635# allowed to execute the `suexec' wrapper. Expected to be the user the 638# allowed to execute the `suexec' wrapper. Expected to be the user the
636# httpd server normally runs as. 639# httpd server normally runs as.
637# Possible: any user name 640# Possible: any user name
638# Default: www 641# Default: www
639 642
640APACHE_GROUP?= www 643APACHE_GROUP?= www
641# Used in apache, apache2, squirrelmail, and iasp to specify 644# Used in apache, apache2, squirrelmail, and iasp to specify
642# the default group of the user allowed to execute the `suexec' wrapper. 645# the default group of the user allowed to execute the `suexec' wrapper.
643# Expected to be the group the httpd server normally runs as. 646# Expected to be the group the httpd server normally runs as.
644# Possible: any group name 647# Possible: any group name
645# Default: www 648# Default: www
646 649
647#APACHE_SUEXEC_CONFIGURE_ARGS= --suexec-uidmin=1000 650#APACHE_SUEXEC_CONFIGURE_ARGS= --suexec-uidmin=1000
648# Used in apache and apache2 to specify additional suexec options 651# Used in apache and apache2 to specify additional suexec options
649# to be passed to the configure script. 652# to be passed to the configure script.
650# Possible: any --suexec-* options recognized by the Apache configure script. 653# Possible: any --suexec-* options recognized by the Apache configure script.
651# Default: not defined 654# Default: not defined
652 655
653APACHE_SUEXEC_DOCROOT?= ${LOCALBASE}/share/httpd/htdocs 656APACHE_SUEXEC_DOCROOT?= ${LOCALBASE}/share/httpd/htdocs
654# Used in apache and apache2 to specify the document space in 657# Used in apache and apache2 to specify the document space in
655# which suexec will be allowed to work. 658# which suexec will be allowed to work.
656# Possible: Any valid directory 659# Possible: Any valid directory
657# Default: ${LOCALBASE}/share/httpd/htdocs 660# Default: ${LOCALBASE}/share/httpd/htdocs
658 661
659ARLA_CACHE?= ${LOCALBASE}/cache 662ARLA_CACHE?= ${LOCALBASE}/cache
660# Used in arla to specify the location of the cache used by arla. Should 663# Used in arla to specify the location of the cache used by arla. Should
661# be on a local disk. 664# be on a local disk.
662# Default: ${LOCALBASE}/cache 665# Default: ${LOCALBASE}/cache
663 666
664BIND_DIR?= ${VARBASE}/chroot/named 667BIND_DIR?= ${VARBASE}/chroot/named
665# The directory for BIND system user. 668# The directory for BIND system user.
666# Possible: any valid location 669# Possible: any valid location
667# Default: ${VARBASE}/chroot/named 670# Default: ${VARBASE}/chroot/named
668 671
669BIND_GROUP?= named 672BIND_GROUP?= named
670# System group to run the BIND name server as. Used by the "bind9" package. 673# System group to run the BIND name server as. Used by the "bind9" package.
671# Possible: any group name 674# Possible: any group name
672# Default: named 675# Default: named
673 676
674BIND_USER?= named 677BIND_USER?= named
675# System user to run the BIND name server as. Used by the "bind9" package. 678# System user to run the BIND name server as. Used by the "bind9" package.
676# Possible: any user name 679# Possible: any user name
677# Default: named 680# Default: named
678 681
679#BULK_PREREQ= 682#BULK_PREREQ=
680# Used during bulk package builds. Packages listed in this variable are 683# Used during bulk package builds. Packages listed in this variable are
681# assumed to be required to build all packages. Only a very limited number 684# assumed to be required to build all packages. Only a very limited number
682# of packages belong in this variable. 685# of packages belong in this variable.
683# Currently pkgtools/digest is always added to this list. 686# Currently pkgtools/digest is always added to this list.
684# Possible: category/pkg 687# Possible: category/pkg
685# Default: not defined 688# Default: not defined
686 689
687CACTI_GROUP?= cacti 690CACTI_GROUP?= cacti
688# System group to run the cacti collection cron jobs as. Used by the 691# System group to run the cacti collection cron jobs as. Used by the
689# "cacti" package. 692# "cacti" package.
690# Possible: any group name 693# Possible: any group name
691# Default: cacti 694# Default: cacti
692 695
693CACTI_USER?= cacti 696CACTI_USER?= cacti
694# System user to run the cacti collection cron jobs as. Used by the 697# System user to run the cacti collection cron jobs as. Used by the
695# "cacti" package. 698# "cacti" package.
696# Possible: any user name 699# Possible: any user name
697# Default: cacti 700# Default: cacti
698 701
699CANNA_GROUP?= daemon 702CANNA_GROUP?= daemon
700# Used in the canna-server-bin package to specify the server group. 703# Used in the canna-server-bin package to specify the server group.
701# Possible: any group name 704# Possible: any group name
702# Default: daemon 705# Default: daemon
703 706
704CANNA_USER?= daemon 707CANNA_USER?= daemon
705# Used in the canna-server-bin package to specify the server user. 708# Used in the canna-server-bin package to specify the server user.
706# Possible: any user name 709# Possible: any user name
707# Default: daemon 710# Default: daemon
708 711
709#CDRECORD_CONF= ${PKG_SYSCONFDIR}/cdrecord.conf 712#CDRECORD_CONF= ${PKG_SYSCONFDIR}/cdrecord.conf
710# The location of the cdrtools/cdrecord configuration file. The 713# The location of the cdrtools/cdrecord configuration file. The
711# sysutils/cdrtools pkg issues a warning if the cdrtools default of 714# sysutils/cdrtools pkg issues a warning if the cdrtools default of
712# /etc/default/cdrecord is changed, and the man pages are updated 715# /etc/default/cdrecord is changed, and the man pages are updated
713# accordingly. This is required by the cdrtools license. 716# accordingly. This is required by the cdrtools license.
714# Possible: any file name 717# Possible: any file name
715# Default: ${PKG_SYSCONFDIR}/cdrecord.conf 718# Default: ${PKG_SYSCONFDIR}/cdrecord.conf
716 719
717CLAMAV_GROUP?= clamav 720CLAMAV_GROUP?= clamav
718# Used in clamav to specify the group to run clamav 721# Used in clamav to specify the group to run clamav
719# Possible: any group name 722# Possible: any group name
720# Default: clamav 723# Default: clamav
721 724
722CLAMAV_USER?= clamav 725CLAMAV_USER?= clamav
723# Used in clamav to specify the user to run clamav 726# Used in clamav to specify the user to run clamav
724# Possible: any user name 727# Possible: any user name
725# Default: clamav 728# Default: clamav
726 729
727CLAMAV_DBDIR?= ${VARBASE}/clamav 730CLAMAV_DBDIR?= ${VARBASE}/clamav
728# Used in clamav to specify the virus database directory 731# Used in clamav to specify the virus database directory
729# Possible: any directory writable by ${CLAMAV_USER} 732# Possible: any directory writable by ${CLAMAV_USER}
730# Default: ${VARBASE}/clamav 733# Default: ${VARBASE}/clamav
731 734
732CONSERVER_DEFAULTHOST?= localhost 735CONSERVER_DEFAULTHOST?= localhost
733# Used by conserver package to specify the master server hostname. 736# Used by conserver package to specify the master server hostname.
734# Possible: any hostname 737# Possible: any hostname
735# Default: localhost 738# Default: localhost
736 739
737CONSERVER_DEFAULTPORT?= 782 740CONSERVER_DEFAULTPORT?= 782
738# Used by conserver package to specify the default listen port. 741# Used by conserver package to specify the default listen port.
739# Possible: 1-65535 742# Possible: 1-65535
740# Default: 782 743# Default: 782
741 744
742CUPS_GROUP?= lp 745CUPS_GROUP?= lp
743# Used in cups to specify the group to run CUPS commands as. 746# Used in cups to specify the group to run CUPS commands as.
744# Possible: any group name 747# Possible: any group name
745# Default: sys 748# Default: sys
746 749
747CUPS_USER?= lp 750CUPS_USER?= lp
748# Used in cups to specify the user to run CUPS commands as and to create 751# Used in cups to specify the user to run CUPS commands as and to create
749# temporary files in the /var/spool/cups/tmp directory. 752# temporary files in the /var/spool/cups/tmp directory.
750# Possible: any user name 753# Possible: any user name
751# Default: lp 754# Default: lp
752 755
753CUPS_SYSTEM_GROUPS?= ${REAL_ROOT_GROUP} 756CUPS_SYSTEM_GROUPS?= ${REAL_ROOT_GROUP}
754# A space separated list of groups to use for CUPS administration privileges. 757# A space separated list of groups to use for CUPS administration privileges.
755# Possible: any group names, except that of ${CUPS_GROUP} 758# Possible: any group names, except that of ${CUPS_GROUP}
756# Default: ${REAL_ROOT_GROUP} 759# Default: ${REAL_ROOT_GROUP}
757 760
758# CYRUS_IDLE 761# CYRUS_IDLE
759# use METHOD for IMAP IDLE 762# use METHOD for IMAP IDLE
760# METHOD is poll, idled or no 763# METHOD is poll, idled or no
761# Default: not defined 764# Default: not defined
762 765
763CYRUS_GROUP?= mail 766CYRUS_GROUP?= mail
764# Used in cyrus-imapd, cyrus-imapd21, and cyrus-sasl to 767# Used in cyrus-imapd, cyrus-imapd21, and cyrus-sasl to
765# specify the group used for installing setuid programs. 768# specify the group used for installing setuid programs.
766# Possible: any group name 769# Possible: any group name
767# Default: mail 770# Default: mail
768 771
769CYRUS_USER?= cyrus 772CYRUS_USER?= cyrus
770# Used in cyrus-imapd, cyrus-imapd21, and cyrus-sasl to 773# Used in cyrus-imapd, cyrus-imapd21, and cyrus-sasl to
771# specify the userid used for installing setuid programs. 774# specify the userid used for installing setuid programs.
772# Possible: any user name 775# Possible: any user name
773# Default: cyrus 776# Default: cyrus
774 777
775DBUS_GROUP?= dbus 778DBUS_GROUP?= dbus
776# Used in the dbus package to specify the group to run dbus as 779# Used in the dbus package to specify the group to run dbus as
777# Possible: any group name 780# Possible: any group name
778# Default: dbus 781# Default: dbus
779 782
780DBUS_USER?= dbus 783DBUS_USER?= dbus
781# Used in the dbus package to specify the user to run dbus as 784# Used in the dbus package to specify the user to run dbus as
782# Possible: any user name 785# Possible: any user name
783# Default: dbus 786# Default: dbus
784 787
785DEFANG_GROUP?= defang 788DEFANG_GROUP?= defang
786# Used in the mimedefang package to specify the group to run commands as 789# Used in the mimedefang package to specify the group to run commands as
787# Possible: any group name 790# Possible: any group name
788# Default: defang 791# Default: defang
789 792
790DEFANG_USER?= defang 793DEFANG_USER?= defang
791# Used in the mimedefang package to specify the user to run commands as 794# Used in the mimedefang package to specify the user to run commands as
792# Possible: any user name 795# Possible: any user name
793# Default: defang 796# Default: defang
794 797
795DEFANG_SPOOLDIR?= ${VARBASE}/spool/MIMEDefang 798DEFANG_SPOOLDIR?= ${VARBASE}/spool/MIMEDefang
796# Location of spool and quarantined files for the mimedefang package 799# Location of spool and quarantined files for the mimedefang package
797# Default: ${VARBASE}/spool/MIMEDefang 800# Default: ${VARBASE}/spool/MIMEDefang
798 801
799#DEFAULT_IRC_SERVER= 802#DEFAULT_IRC_SERVER=
800# Used in ircII to set the default irc server. 803# Used in ircII to set the default irc server.
801# Possible: see the list at 804# Possible: see the list at
802# http://www.irchelp.org/irchelp/networks/servers/efnet.html 805# http://www.irchelp.org/irchelp/networks/servers/efnet.html
803# Default: not defined 806# Default: not defined
804 807
805#DEFAULT_SERIAL_DEVICE= 808#DEFAULT_SERIAL_DEVICE=
806# Used to provide a default setting for the serial device for 809# Used to provide a default setting for the serial device for
807# various packages which communicate over the serial port. 810# various packages which communicate over the serial port.
808# Possible: /dev/your_favorite_serial_device 811# Possible: /dev/your_favorite_serial_device
809# Default: defaults for various machine_archs are set in mk/platform/${OPSYS}.mk 812# Default: defaults for various machine_archs are set in mk/platform/${OPSYS}.mk
810 813
811DIALER_GROUP?= dialer 814DIALER_GROUP?= dialer
812# Used in the xisp package to specify the default group for the 815# Used in the xisp package to specify the default group for the
813# xisp binaries. Also the modem device and pppd and chat should 816# xisp binaries. Also the modem device and pppd and chat should
814# have access permissions by this group. 817# have access permissions by this group.
815# Possible: dialer, dip, uucp, root, dialout, or any other group. 818# Possible: dialer, dip, uucp, root, dialout, or any other group.
816# Default: dialer 819# Default: dialer
817 820
818DT_LAYOUT?= US 821DT_LAYOUT?= US
819# Used by dt package to specify the keyboard layout. 822# Used by dt package to specify the keyboard layout.
820# Possible: US, FI, FR, GER, DV 823# Possible: US, FI, FR, GER, DV
821# Default: FI 824# Default: FI
822 825
823ELK_GUI?= none 826ELK_GUI?= none
824# Used by elk to determine which GUI API modules are enabled. 827# Used by elk to determine which GUI API modules are enabled.
825# Possible: none, or some combination of xaw and/or motif 828# Possible: none, or some combination of xaw and/or motif
826# Default: none 829# Default: none
827 830
828EMACS_TYPE?= emacs24 831EMACS_TYPE?= emacs24
829# Used by emacs/modules.mk to determine which emacs version should be installed 832# Used by emacs/modules.mk to determine which emacs version should be installed
830# and emacs lisp packages should be built for. 833# and emacs lisp packages should be built for.
831# Possible: emacs24, emacs23, emacs23nox, emacs22, emacs22nox, 834# Possible: emacs24, emacs23, emacs23nox, emacs22, emacs22nox,
832# emacs21, emacs21nox, emacs20, 835# emacs21, emacs21nox, emacs20,
833# xemacs214, xemacs215 836# xemacs214, xemacs215
834# Default: emacs24 837# Default: emacs24
835 838
836EXIM_GROUP?= mail 839EXIM_GROUP?= mail
837# Used in the exim package to specify the server group. 840# Used in the exim package to specify the server group.
838# Possible: any group name 841# Possible: any group name
839# Default: mail 842# Default: mail
840 843
841EXIM_USER?= mail 844EXIM_USER?= mail
842# Used in the exim package to specify the server user. 845# Used in the exim package to specify the server user.
843# Possible: any user name 846# Possible: any user name
844# Default: mail 847# Default: mail
845 848
846#FLUXBOX_USE_XINERAMA?= NO 849#FLUXBOX_USE_XINERAMA?= NO
847# Compile flukebox with xinerama extensions 850# Compile flukebox with xinerama extensions
848# Possible: YES, NO 851# Possible: YES, NO
849# Default: NO 852# Default: NO
850 853
851#FLUXBOX_USE_KDE?= NO 854#FLUXBOX_USE_KDE?= NO
852# Compile flukebox with KDE support 855# Compile flukebox with KDE support
853# Possible: YES, NO 856# Possible: YES, NO
854# Default: NO 857# Default: NO
855 858
856#FLUXBOX_USE_GNOME?= NO 859#FLUXBOX_USE_GNOME?= NO
857# Compile flukebox with GNOME support 860# Compile flukebox with GNOME support
858# Possible: YES, NO 861# Possible: YES, NO
859# Default: NO 862# Default: NO
860 863
861#FLUXBOX_USE_XFT?= YES 864#FLUXBOX_USE_XFT?= YES
862# Compile flukebox with Xft support 865# Compile flukebox with Xft support
863# Possible: YES, NO 866# Possible: YES, NO
864# Default: YES 867# Default: YES
865 868
866FOX_USE_XUNICODE?= YES 869FOX_USE_XUNICODE?= YES
867# Used in fox to build in support for Unicode by XUnicode. See 870# Used in fox to build in support for Unicode by XUnicode. See
868# http://www.ab.wakwak.com/~tino/jatk/fox/ (in japanese) for more information. 871# http://www.ab.wakwak.com/~tino/jatk/fox/ (in japanese) for more information.
869# Possible: YES, NO 872# Possible: YES, NO
870# Default: YES 873# Default: YES
871 874
872FREEWNN_USER?= wnn 875FREEWNN_USER?= wnn
873# Used in the ja-freewnn-server-bin package to specify the Free wnn user. 876# Used in the ja-freewnn-server-bin package to specify the Free wnn user.
874# Possible: any user name 877# Possible: any user name
875# Default: wnn 878# Default: wnn
876 879
877FREEWNN_GROUP?= jserver 880FREEWNN_GROUP?= jserver
878# Used in the ja-freewnn-server-bin package to specify the Free wnn group. 881# Used in the ja-freewnn-server-bin package to specify the Free wnn group.
879# Possible: any group name 882# Possible: any group name
880# Default: jserver 883# Default: jserver
881 884
882GAMES_USER?= games 885GAMES_USER?= games
883# Used by games to own writeable material, normally in ${VARBASE}. 886# Used by games to own writeable material, normally in ${VARBASE}.
884# GAMES_USER has historically been "games" but in the absence of setuid 887# GAMES_USER has historically been "games" but in the absence of setuid
885# games, which are generally a bad idea, a games user is fairly pointless 888# games, which are generally a bad idea, a games user is fairly pointless
886# and is expected to be removed in the future. 889# and is expected to be removed in the future.
887# See also: GAMES_GROUP, USE_GAMESGROUP 890# See also: GAMES_GROUP, USE_GAMESGROUP
888# Possible: any user name 891# Possible: any user name
889# Default: games 892# Default: games
890 893
891GAMES_GROUP?= games 894GAMES_GROUP?= games
892# Used by games to own writeable material, normally in ${VARBASE}. 895# Used by games to own writeable material, normally in ${VARBASE}.
893# See also: GAMES_USER, GAMEMODE, GAMEDIRMODE, GAMEDATAMODE, USE_GAMESGROUP 896# See also: GAMES_USER, GAMEMODE, GAMEDIRMODE, GAMEDATAMODE, USE_GAMESGROUP
894# Possible: any group name 897# Possible: any group name
895# Default: games 898# Default: games
896 899
897GAMEMODE?= 2555 900GAMEMODE?= 2555
898# Used by setgid games to install the setgid executable itself. 901# Used by setgid games to install the setgid executable itself.
899# Note that USE_GAMESGROUP must be set to make the games group actually 902# Note that USE_GAMESGROUP must be set to make the games group actually
900# exist. 903# exist.
901# See also: GAMES_GROUP, GAMEDIRMODE, GAMEDATAMODE, USE_GAMESGROUP 904# See also: GAMES_GROUP, GAMEDIRMODE, GAMEDATAMODE, USE_GAMESGROUP
902# Possible: any mode 905# Possible: any mode
903# Default: 2555 906# Default: 2555
904 907
905GAMEDIRMODE?= 775 908GAMEDIRMODE?= 775
906# Used by setgid games to allow writing to a group-owned directory for 909# Used by setgid games to allow writing to a group-owned directory for
907# e.g. logfiles. Note that this variable should only be used for 910# e.g. logfiles. Note that this variable should only be used for
908# directories where the game needs write access at runtime; otherwise 911# directories where the game needs write access at runtime; otherwise
909# stick to ${PKGDIRMODE}. 912# stick to ${PKGDIRMODE}.
910# See also: GAMES_USER, GAMES_GROUP, GAMEMODE, USE_GAMESGROUP 913# See also: GAMES_USER, GAMES_GROUP, GAMEMODE, USE_GAMESGROUP
911# Possible: any mode 914# Possible: any mode
912# Default: 775 915# Default: 775
913 916
914GAMEDATAMODE?= 664 917GAMEDATAMODE?= 664
915# Used by setgid games as the permissions for writeable material, such 918# Used by setgid games as the permissions for writeable material, such
916# as score files, normally found in ${VARBASE}. 919# as score files, normally found in ${VARBASE}.
917# See also: GAMES_USER, GAMES_GROUP, USE_GAMESGROUP 920# See also: GAMES_USER, GAMES_GROUP, USE_GAMESGROUP
918# Possible: any file ownership 921# Possible: any file ownership
919# Default: 664 922# Default: 664
920 923
921GAMEGRP?= ${GAMES_GROUP} 924GAMEGRP?= ${GAMES_GROUP}
922# Legacy form of GAMES_GROUP; should only be used in the context of 925# Legacy form of GAMES_GROUP; should only be used in the context of
923# supporting packages that use bsd.*.mk. 926# supporting packages that use bsd.*.mk.
924# See also: GAMES_GROUP, USE_GAMESGROUP 927# See also: GAMES_GROUP, USE_GAMESGROUP
925# Possible: any group name 928# Possible: any group name
926# Default: GAMES_GROUP 929# Default: GAMES_GROUP
927 930
928GAMEOWN?= ${GAMES_USER} 931GAMEOWN?= ${GAMES_USER}
929# Legacy form of GAMES_USER; should only be used in the context of 932# Legacy form of GAMES_USER; should only be used in the context of
930# supporting packages that use bsd.*.mk. 933# supporting packages that use bsd.*.mk.
931# See also: GAMES_USER 934# See also: GAMES_USER
932# Possible: any user name 935# Possible: any user name
933# Default: GAMES_USER 936# Default: GAMES_USER
934 937
935#GRUB_NETWORK_CARDS= 938#GRUB_NETWORK_CARDS=
936# Compile netboot support for the listed network interface cards into GRUB. 939# Compile netboot support for the listed network interface cards into GRUB.
937# Use e.g. "rtl8139" for RealTek 8139 support or "eepro100 epic100" for 940# Use e.g. "rtl8139" for RealTek 8139 support or "eepro100 epic100" for
938# Intel Etherexpress Pro/100 and SMC EtherPower II support. 941# Intel Etherexpress Pro/100 and SMC EtherPower II support.
939# Default: not defined (-> no netboot support) 942# Default: not defined (-> no netboot support)
940 943
941#GRUB_PRESET_COMMAND= 944#GRUB_PRESET_COMMAND=
942# Specifies a single command that will be embedded into GRUB's stage2 and 945# Specifies a single command that will be embedded into GRUB's stage2 and
943# executed at boot time as a default configuration file. This is usually 946# executed at boot time as a default configuration file. This is usually
944# useful to create stage2 files with automated diskless support; you should 947# useful to create stage2 files with automated diskless support; you should
945# set this variable to "bootp", "dhcp" or "rarp", and use it together 948# set this variable to "bootp", "dhcp" or "rarp", and use it together
946# GRUB_NETWORK_CARDS. 949# GRUB_NETWORK_CARDS.
947# Default: not defined 950# Default: not defined
948 951
949#GRUB_SCAN_ARGS= 952#GRUB_SCAN_ARGS=
950# Can be used to supply additional configure arguments for netboot support in 953# Can be used to supply additional configure arguments for netboot support in
951# GRUB. Set e.g. "GRUB_NETWORK_CARDS" to "ne" and "GRUB_SCAN_ARGS" to 954# GRUB. Set e.g. "GRUB_NETWORK_CARDS" to "ne" and "GRUB_SCAN_ARGS" to
952# "--enable-ne-scan=0x300" to let the boot loader search for an NE 2000 ISA 955# "--enable-ne-scan=0x300" to let the boot loader search for an NE 2000 ISA
953# card at I/O offset 0x300. 956# card at I/O offset 0x300.
954# Default: not defined 957# Default: not defined
955 958
956HASKELL_COMPILER?= ghc 959HASKELL_COMPILER?= ghc
957# Used by haskell.mk to determine which Haskell compiler should be 960# Used by haskell.mk to determine which Haskell compiler should be
958# used for building Haskell packages. 961# used for building Haskell packages.
959# Possible: ghc 962# Possible: ghc
960# Default: ghc 963# Default: ghc
961 964
962HOWL_GROUP?= howl 965HOWL_GROUP?= howl
963# System group to run howl's mDNS responder as. 966# System group to run howl's mDNS responder as.
964# Possible: any group name 967# Possible: any group name
965# Default: howl 968# Default: howl
966 969
967HOWL_USER?= howl 970HOWL_USER?= howl
968# System user to run howl's mDNS responder as. 971# System user to run howl's mDNS responder as.
969# Possible: any user name 972# Possible: any user name
970# Default: howl 973# Default: howl
971 974
972ICECAST_CHROOTDIR?= ${VARBASE}/chroot/icecast 975ICECAST_CHROOTDIR?= ${VARBASE}/chroot/icecast
973# Used in icecast2 to specify the chroot directory in which icecast 976# Used in icecast2 to specify the chroot directory in which icecast
974# will be allowed to work. 977# will be allowed to work.
975# Possible: Any valid directory 978# Possible: Any valid directory
976# Default: ${VARBASE}/chroot/icecast 979# Default: ${VARBASE}/chroot/icecast
977 980
978#ICECAST_CHUNKLEN=512 981#ICECAST_CHUNKLEN=512
979# If you want a larger backlog for each client, which will allow for 982# If you want a larger backlog for each client, which will allow for
980# worse network congestion or other network errors before kicking the 983# worse network congestion or other network errors before kicking the
981# client, increase the ICECAST_CHUNKLEN value. 984# client, increase the ICECAST_CHUNKLEN value.
982# Default: 64 985# Default: 64
983 986
984#ICECAST_SOURCE_BUFFSIZE=8192 987#ICECAST_SOURCE_BUFFSIZE=8192
985# SOURCE_BUFFSIZE sets how many bytes will be read from the source 988# SOURCE_BUFFSIZE sets how many bytes will be read from the source
986# before trying to send this chunk to the clients. If your server will 989# before trying to send this chunk to the clients. If your server will
987# take on a lot of listeners, or stream very high bitrate mpeg data, 990# take on a lot of listeners, or stream very high bitrate mpeg data,
988# like video mpeg streams, and if you system supports it, you should 991# like video mpeg streams, and if you system supports it, you should
989# increase this value to 65535 or something similar. 992# increase this value to 65535 or something similar.
990# Default: 8192 993# Default: 8192
991 994
992IMAP_UW_CCLIENT_MBOX_FMT?= unix 995IMAP_UW_CCLIENT_MBOX_FMT?= unix
993# Used in imap-uw to set the default format used by c-client programs for 996# Used in imap-uw to set the default format used by c-client programs for
994# new mailbox creation. Check the UW IMAP documentation for more details 997# new mailbox creation. Check the UW IMAP documentation for more details
995# regarding the pros and cons of the various mailbox formats. 998# regarding the pros and cons of the various mailbox formats.
996# 999#
997# Possible: mbox, mbx, mh, mmdf, mtx, mx, news, phile, tenex, unix 1000# Possible: mbox, mbx, mh, mmdf, mtx, mx, news, phile, tenex, unix
998# Default: unix 1001# Default: unix
999 1002
1000#IMAP_UW_MAILSPOOLHOME=.MailBox 1003#IMAP_UW_MAILSPOOLHOME=.MailBox
1001# To default user mailboxes to their home directory, 1004# To default user mailboxes to their home directory,
1002# specify the name of the mailbox file. 1005# specify the name of the mailbox file.
1003# Possible: Any valid filename, not defined 1006# Possible: Any valid filename, not defined
1004# Default: not defined 1007# Default: not defined
1005 1008
1006IMDICTDIR?= ${VARBASE}/dict 1009IMDICTDIR?= ${VARBASE}/dict
1007# Specify the directory for input method's dictionary installation. 1010# Specify the directory for input method's dictionary installation.
1008# Possible: any valid location 1011# Possible: any valid location
1009# Default: ${VARBASE}/dict 1012# Default: ${VARBASE}/dict
1010 1013
1011INN_DATA_DIR?= ${VARBASE}/news 1014INN_DATA_DIR?= ${VARBASE}/news
1012# Used by inn to specify the data directory. 1015# Used by inn to specify the data directory.
1013# Possible: any path you like 1016# Possible: any path you like
1014# Default: ${VARBASE}/news 1017# Default: ${VARBASE}/news
1015 1018
1016INN_USER?= news 1019INN_USER?= news
1017# Used by inn to specify the username 1020# Used by inn to specify the username
1018# Possible: any valid username 1021# Possible: any valid username
1019# Default: news 1022# Default: news
1020 1023
1021INN_GROUP?= news 1024INN_GROUP?= news
1022# Used by inn to specify the groupname 1025# Used by inn to specify the groupname
1023# Possible: any valid groupname 1026# Possible: any valid groupname
1024# Default: news 1027# Default: news
1025 1028
1026IRCD_HYBRID_NICLEN?= 9 1029IRCD_HYBRID_NICLEN?= 9
1027# Used by ircd-hybrid. Sets the maximum NICK length. 1030# Used by ircd-hybrid. Sets the maximum NICK length.
1028# Note that this must be consistent across your entire network. 1031# Note that this must be consistent across your entire network.
1029# Possible: any valid number 1032# Possible: any valid number
1030# Default: 9 1033# Default: 9
1031 1034
1032IRCD_HYBRID_TOPICLEN?= 120 1035IRCD_HYBRID_TOPICLEN?= 120
1033# Used by ircd-hybrid. Sets the maximum TOPIC length. 1036# Used by ircd-hybrid. Sets the maximum TOPIC length.
1034# Note that this must be consistent across your entire network. 1037# Note that this must be consistent across your entire network.
1035# Possible: any valid number 1038# Possible: any valid number
1036# Default: 120 1039# Default: 120
1037 1040
1038#IRCD_HYBRID_SYSLOG_EVENTS?= 1041#IRCD_HYBRID_SYSLOG_EVENTS?=
1039# Used by ircd-hybrid. Enables syslog logging, with events you specify 1042# Used by ircd-hybrid. Enables syslog logging, with events you specify
1040# (none is okay too, and logs the most essential messages only.) 1043# (none is okay too, and logs the most essential messages only.)
1041# Possible: kill/squit/connect/users/oper, separated by spaces, in quotes 1044# Possible: kill/squit/connect/users/oper, separated by spaces, in quotes
1042# Default: not defined 1045# Default: not defined
1043 1046
1044IRCD_HYBRID_SYSLOG_FACILITY?= LOG_LOCAL4 1047IRCD_HYBRID_SYSLOG_FACILITY?= LOG_LOCAL4
1045# Used by ircd-hybrid. Specify which syslog facility the daemon should use 1048# Used by ircd-hybrid. Specify which syslog facility the daemon should use
1046# when IRCD_HYBRID_SYSLOG_EVENTS is defined. 1049# when IRCD_HYBRID_SYSLOG_EVENTS is defined.
1047# Possible: any syslog facility (LOG_*) 1050# Possible: any syslog facility (LOG_*)
1048# Default: LOG_LOCAL4 1051# Default: LOG_LOCAL4
1049 1052
1050#IRCD_HYBRID_MAXCONN?= 1053#IRCD_HYBRID_MAXCONN?=
1051# Used by ircd-hybrid. Sets the maximum number of connections the ircd 1054# Used by ircd-hybrid. Sets the maximum number of connections the ircd
1052# can support. Note that this also twiddles the HARD_FDLIMIT. 1055# can support. Note that this also twiddles the HARD_FDLIMIT.
1053# This value is typically automagically set by ./configure 1056# This value is typically automagically set by ./configure
1054# Possible: any valid number 1057# Possible: any valid number
1055# Default: not defined 1058# Default: not defined
1056 1059
1057IRCD_HYBRID_IRC_USER?= irc 1060IRCD_HYBRID_IRC_USER?= irc
1058# Used by ircd-hybrid. Specify the user name under which the daemon runs. 1061# Used by ircd-hybrid. Specify the user name under which the daemon runs.
1059# Possible: any user name 1062# Possible: any user name
1060# Default: irc 1063# Default: irc
1061 1064
1062IRCD_HYBRID_IRC_GROUP?= irc 1065IRCD_HYBRID_IRC_GROUP?= irc
1063# Used by ircd-hybrid. Specify the group name under which the daemon runs. 1066# Used by ircd-hybrid. Specify the group name under which the daemon runs.
1064# Possible: any group name 1067# Possible: any group name
1065# Default: irc 1068# Default: irc
1066 1069
1067#IRRD_USE_PGP= 1070#IRRD_USE_PGP=
1068# Used by irrd package to specify the version of PGP to use, if any. 1071# Used by irrd package to specify the version of PGP to use, if any.
1069# Possible: 5, 2, not defined 1072# Possible: 5, 2, not defined
1070# Default: not defined 1073# Default: not defined
1071# [XXX: configure will locate pgpv or pgp] 1074# [XXX: configure will locate pgpv or pgp]
1072 1075
1073JABBERD_USER?= jabberd 1076JABBERD_USER?= jabberd
1074# Used in jabberd to specify the user used to run the daemon. 1077# Used in jabberd to specify the user used to run the daemon.
1075# Possible: any valid username 1078# Possible: any valid username
1076# Default: jabberd 1079# Default: jabberd
1077 1080
1078JABBERD_GROUP?= jabberd 1081JABBERD_GROUP?= jabberd
1079# Used in jabberd to specify the group userd to run the daemon. 1082# Used in jabberd to specify the group userd to run the daemon.
1080# Possible: any valid group 1083# Possible: any valid group
1081# Default: jabberd 1084# Default: jabberd
1082 1085
1083JABBERD_LOGDIR?= ${VARBASE}/log/jabberd 1086JABBERD_LOGDIR?= ${VARBASE}/log/jabberd
1084# Used in jabberd to specify the default directory under which log 1087# Used in jabberd to specify the default directory under which log
1085# files are placed. 1088# files are placed.
1086# Possible: any directory 1089# Possible: any directory
1087# Default: ${VARBASE}/log/jabberd 1090# Default: ${VARBASE}/log/jabberd
1088 1091
1089JABBERD_SPOOLDIR?= ${VARBASE}/spool/jabberd 1092JABBERD_SPOOLDIR?= ${VARBASE}/spool/jabberd
1090# Used in jabberd to specify the default directory under which server 1093# Used in jabberd to specify the default directory under which server
1091# information is stored. 1094# information is stored.
1092# Possible: any directory 1095# Possible: any directory
1093# Default: ${VARBASE}/spool/jabberd 1096# Default: ${VARBASE}/spool/jabberd
1094 1097
1095JABBERD_PIDDIR?= ${VARBASE}/run/jabberd 1098JABBERD_PIDDIR?= ${VARBASE}/run/jabberd
1096# Used in jabberd to specify the default directory under which pid 1099# Used in jabberd to specify the default directory under which pid
1097# files are placed. 1100# files are placed.
1098# Possible: any directory 1101# Possible: any directory
1099# Default: ${VARBASE}/run/jabberd 1102# Default: ${VARBASE}/run/jabberd
1100 1103
1101JAKARTA_HOME?= ${JAVA_HOME}/jakarta 1104JAKARTA_HOME?= ${JAVA_HOME}/jakarta
1102# Used by the www/jakarta-tomcat package to choose an install location 1105# Used by the www/jakarta-tomcat package to choose an install location
1103# Possible: any directory 1106# Possible: any directory
1104# Default: ${JAVA_HOME}/jakarta 1107# Default: ${JAVA_HOME}/jakarta
1105 1108
1106#KERBEROS= 1109#KERBEROS=
1107# Used in many packages to specify use of a Kerberos (or compatible) 1110# Used in many packages to specify use of a Kerberos (or compatible)
1108# subsystem. Requires Kerberos libraries in /usr/lib. 1111# subsystem. Requires Kerberos libraries in /usr/lib.
1109# Possible: defined, not defined 1112# Possible: defined, not defined
1110# Default: not defined 1113# Default: not defined
1111 1114
1112#KERMIT_SUID_UUCP 1115#KERMIT_SUID_UUCP
1113# If set to YES or yes, install kermit binary set-uid uucp. Permits an 1116# If set to YES or yes, install kermit binary set-uid uucp. Permits an
1114# unprivileged user to access the serial ports, with default permissions 1117# unprivileged user to access the serial ports, with default permissions
1115# on the /dev/tty0* special files. 1118# on the /dev/tty0* special files.
1116# Possible: YES, yes, not defined 1119# Possible: YES, yes, not defined
1117# Default: not defined 1120# Default: not defined
1118 1121
1119#KJS_USE_PCRE= 1122#KJS_USE_PCRE=
1120# Used in kdelibs2 to determine if kjs (javascript) should use Perl 1123# Used in kdelibs2 to determine if kjs (javascript) should use Perl
1121# Compatible Regular Expressions (pcre) 1124# Compatible Regular Expressions (pcre)
1122# Possible: yes, not defined 1125# Possible: yes, not defined
1123# Default: not defined 1126# Default: not defined
1124 1127
1125#KNEWS_DOMAIN_FILE= 1128#KNEWS_DOMAIN_FILE=
1126# Used in the knews package to set the domain name from the contents 1129# Used in the knews package to set the domain name from the contents
1127# of this file. 1130# of this file.
1128# Possible: any valid path 1131# Possible: any valid path
1129# Default: none 1132# Default: none
1130 1133
1131#KNEWS_DOMAIN_NAME= 1134#KNEWS_DOMAIN_NAME=
1132# Used in the knews package to set the domain name. 1135# Used in the knews package to set the domain name.
1133# Possible: almost anything really, usually a FQDN. 1136# Possible: almost anything really, usually a FQDN.
1134# Default: none 1137# Default: none
1135 1138
1136#LIBDVDCSS_HOMEPAGE= 1139#LIBDVDCSS_HOMEPAGE=
1137# Used in libdvdcss package as the homepage. 1140# Used in libdvdcss package as the homepage.
1138# In order to ensure compliance with U.S. and international law, please 1141# In order to ensure compliance with U.S. and international law, please
1139# do not modify this variable to provide pointers to the homepage 1142# do not modify this variable to provide pointers to the homepage
1140# for this software or submit any PRs telling us the contents of the 1143# for this software or submit any PRs telling us the contents of the
1141# LIBDVDCSS_HOMEPAGE definition in this Makefile. 1144# LIBDVDCSS_HOMEPAGE definition in this Makefile.
1142# Possible: any libdvdcss site 1145# Possible: any libdvdcss site
1143# Default: not defined 1146# Default: not defined
1144 1147
1145#LIBDVDCSS_MASTER_SITES= 1148#LIBDVDCSS_MASTER_SITES=
1146# Used in libdvdcss package as the master site. 1149# Used in libdvdcss package as the master site.
1147# In order to ensure compliance with U.S. and international law, please 1150# In order to ensure compliance with U.S. and international law, please
1148# do not modify this variable to provide pointers to the homepage 1151# do not modify this variable to provide pointers to the homepage
1149# for this software or submit any PRs telling us the contents of the 1152# for this software or submit any PRs telling us the contents of the
1150# LIBDVDCSS_MASTER_SITES definition in this Makefile. 1153# LIBDVDCSS_MASTER_SITES definition in this Makefile.
1151# Possible: any libdvdcss site 1154# Possible: any libdvdcss site
1152# Default: not defined 1155# Default: not defined
1153 1156
1154#LATEX2HTML_ICONPATH= 1157#LATEX2HTML_ICONPATH=
1155# Used in the latex2html package to set URL prefix for where to 1158# Used in the latex2html package to set URL prefix for where to
1156# find latex2html's icons. 1159# find latex2html's icons.
1157# Possible: a URL prefix 1160# Possible: a URL prefix
1158# Default: none 1161# Default: none
1159 1162
1160LEAFNODE_DATA_DIR?= ${VARBASE}/news 1163LEAFNODE_DATA_DIR?= ${VARBASE}/news
1161# Used by leafnode to specify the data directory. 1164# Used by leafnode to specify the data directory.
1162# Possible: any path you like 1165# Possible: any path you like
1163# Default: ${VARBASE}/news 1166# Default: ${VARBASE}/news
1164# Note: default is the same as INN_DATA_DIR 1167# Note: default is the same as INN_DATA_DIR
1165 1168
1166LEAFNODE_USER?= news 1169LEAFNODE_USER?= news
1167# Used by leafnode to specify the username 1170# Used by leafnode to specify the username
1168# Possible: any valid username 1171# Possible: any valid username
1169# Default: news 1172# Default: news
1170# Note: default is the same as INN_USER 1173# Note: default is the same as INN_USER
1171 1174
1172LEAFNODE_GROUP?= news 1175LEAFNODE_GROUP?= news
1173# Used by leafnode to specify the groupname 1176# Used by leafnode to specify the groupname
1174# Possible: any valid groupname 1177# Possible: any valid groupname
1175# Default: news 1178# Default: news
1176# Note: default is the same as INN_GROUP 1179# Note: default is the same as INN_GROUP
1177 1180
1178LINUX_LOCALES?= \ 1181LINUX_LOCALES?= \
1179 af ar bg br ca cs cy da de el en eo es et eu fi fo fr ga gl \ 1182 af ar bg br ca cs cy da de el en eo es et eu fi fo fr ga gl \
1180 he hr hu hy id is it ja ka kl ko lo lt lv nl no oc pl pt ro \ 1183 he hr hu hy id is it ja ka kl ko lo lt lv nl no oc pl pt ro \
1181 ru sk sl sr sv th tr uk vi wa zh 1184 ru sk sl sr sv th tr uk vi wa zh
1182# Used in linux-locale package to install specify language(s) 1185# Used in linux-locale package to install specify language(s)
1183# Possible: af ar bg br ca cs cy da de el en eo es et eu fi fo fr ga gl \ 1186# Possible: af ar bg br ca cs cy da de el en eo es et eu fi fo fr ga gl \
1184# he hr hu hy id is it ja ka kl ko lo lt lv nl no oc pl pt ro \ 1187# he hr hu hy id is it ja ka kl ko lo lt lv nl no oc pl pt ro \
1185# ru sk sl sr sv th tr uk vi wa zh 1188# ru sk sl sr sv th tr uk vi wa zh
1186# Default: all languages 1189# Default: all languages
1187 1190
1188MAILAGENT_DOMAIN?= example.com 1191MAILAGENT_DOMAIN?= example.com
1189MAILAGENT_EMAIL?= testuser@example.com 1192MAILAGENT_EMAIL?= testuser@example.com
1190MAILAGENT_FQDN?= test.example.com 1193MAILAGENT_FQDN?= test.example.com
1191MAILAGENT_ORGANIZATION?= Example Company 1194MAILAGENT_ORGANIZATION?= Example Company
1192# Domain name, admin email address, fully qualified hostname of the server, 1195# Domain name, admin email address, fully qualified hostname of the server,
1193# name of the organization for mail/mailagent. 1196# name of the organization for mail/mailagent.
1194# Possible: valid hostname/email addresses/any company name 1197# Possible: valid hostname/email addresses/any company name
1195# Defaults: see above 1198# Defaults: see above
1196 1199
1197MAJORDOMO_HOMEDIR?= ${VARBASE}/majordomo 1200MAJORDOMO_HOMEDIR?= ${VARBASE}/majordomo
1198# Used by the majordomo package as the directory the lists dir is in 1201# Used by the majordomo package as the directory the lists dir is in
1199# also used by the distribute package 1202# also used by the distribute package
1200# Possible: any directory. 1203# Possible: any directory.
1201# Default: ${VARBASE}/majordomo 1204# Default: ${VARBASE}/majordomo
1202 1205
1203#MAKEINFO_ARGS?= 1206#MAKEINFO_ARGS?=
1204# flags to be passed to makeinfo(1), if any. Warning: only use if you 1207# flags to be passed to makeinfo(1), if any. Warning: only use if you
1205# know what you're doing, may break PLISTs. 1208# know what you're doing, may break PLISTs.