Tue Apr 23 03:25:39 2024 UTC (16d)
Switch to mesa 21

Works well enough for me on various GPUs, let's try it out. Can be easily
reverted if anyone encounters major issues.


(maya)
diff -r1.348 -r1.349 src/UPDATING
diff -r1.1367 -r1.1368 src/share/mk/bsd.own.mk

cvs diff -r1.348 -r1.349 src/UPDATING (expand / switch to unified diff)

--- src/UPDATING 2024/04/20 14:06:47 1.348
+++ src/UPDATING 2024/04/23 03:25:39 1.349
@@ -1,34 +1,37 @@ @@ -1,34 +1,37 @@
1$NetBSD: UPDATING,v 1.348 2024/04/20 14:06:47 rillig Exp $ 1$NetBSD: UPDATING,v 1.349 2024/04/23 03:25:39 maya Exp $
2 2
3This file (UPDATING) is intended to be a brief reference to recent 3This file (UPDATING) is intended to be a brief reference to recent
4changes that might cause problems in the build process, and a guide for 4changes that might cause problems in the build process, and a guide for
5what to do if something doesn't work. 5what to do if something doesn't work.
6 6
7For a more detailed description of the recommended way to build NetBSD 7For a more detailed description of the recommended way to build NetBSD
8using build.sh, see the BUILDING file. 8using build.sh, see the BUILDING file.
9 9
10Note that much of the advice in this UPDATING file was written before 10Note that much of the advice in this UPDATING file was written before
11build.sh existed. Nevertheless, the advice here may be useful for 11build.sh existed. Nevertheless, the advice here may be useful for
12working around specific problems with build.sh. 12working around specific problems with build.sh.
13 13
14Sections are marked with "^^^^^". After the section on "Recent changes" 14Sections are marked with "^^^^^". After the section on "Recent changes"
15are several sections containing more general information. 15are several sections containing more general information.
16 16
17See also: BUILDING, build.sh, Makefile. 17See also: BUILDING, build.sh, Makefile.
18 18
19Recent changes: 19Recent changes:
20^^^^^^^^^^^^^^^ 20^^^^^^^^^^^^^^^
21 21
 2220240423:
 23 Update builds with x11 may fail after switching to Mesa 21.
 24
2220240410: 2520240410:
23 Update builds may require manually deleting 26 Update builds may require manually deleting
24 $DESTDIR/var/run/named (and, potentially, 27 $DESTDIR/var/run/named (and, potentially,
25 $DESTDIR/var/run/lwresd) in order to avoid checkflist failure. 28 $DESTDIR/var/run/lwresd) in order to avoid checkflist failure.
26 29
2720240409: 3020240409:
28 32-bit compatibility libraries were moved into the base32 31 32-bit compatibility libraries were moved into the base32
29 and debug32 sets. HTML man pages were moved into the manhtml set. 32 and debug32 sets. HTML man pages were moved into the manhtml set.
30 33
3120230828: 3420230828:
32 If: 35 If:
33 - you updated to current and ran postinstall between 20230826 36 - you updated to current and ran postinstall between 20230826
34 and 20230828 inclusive, and 37 and 20230828 inclusive, and

cvs diff -r1.1367 -r1.1368 src/share/mk/bsd.own.mk (expand / switch to unified diff)

--- src/share/mk/bsd.own.mk 2024/04/07 14:40:34 1.1367
+++ src/share/mk/bsd.own.mk 2024/04/23 03:25:39 1.1368
@@ -1,14 +1,14 @@ @@ -1,14 +1,14 @@
1# $NetBSD: bsd.own.mk,v 1.1367 2024/04/07 14:40:34 tsutsui Exp $ 1# $NetBSD: bsd.own.mk,v 1.1368 2024/04/23 03:25:39 maya Exp $
2 2
3# This needs to be before bsd.init.mk 3# This needs to be before bsd.init.mk
4.if defined(BSD_MK_COMPAT_FILE) 4.if defined(BSD_MK_COMPAT_FILE)
5.include <${BSD_MK_COMPAT_FILE}> 5.include <${BSD_MK_COMPAT_FILE}>
6.endif 6.endif
7 7
8.if !defined(_BSD_OWN_MK_) 8.if !defined(_BSD_OWN_MK_)
9_BSD_OWN_MK_=1 9_BSD_OWN_MK_=1
10 10
11MAKECONF?= /etc/mk.conf 11MAKECONF?= /etc/mk.conf
12.-include "${MAKECONF}" 12.-include "${MAKECONF}"
13 13
14# 14#
@@ -1310,27 +1310,27 @@ MKTEGRAFIRMWARE.evbarm= yes @@ -1310,27 +1310,27 @@ MKTEGRAFIRMWARE.evbarm= yes
1310MKDTB.aarch64= yes 1310MKDTB.aarch64= yes
1311MKDTB.aarch64eb= yes 1311MKDTB.aarch64eb= yes
1312MKDTB.earmv6= yes 1312MKDTB.earmv6= yes
1313MKDTB.earmv6hf= yes 1313MKDTB.earmv6hf= yes
1314MKDTB.earmv6eb= yes 1314MKDTB.earmv6eb= yes
1315MKDTB.earmv6hfeb= yes 1315MKDTB.earmv6hfeb= yes
1316MKDTB.earmv7= yes 1316MKDTB.earmv7= yes
1317MKDTB.earmv7hf= yes 1317MKDTB.earmv7hf= yes
1318MKDTB.earmv7eb= yes 1318MKDTB.earmv7eb= yes
1319MKDTB.earmv7hfeb= yes 1319MKDTB.earmv7hfeb= yes
1320MKDTB.riscv32= yes 1320MKDTB.riscv32= yes
1321MKDTB.riscv64= yes 1321MKDTB.riscv64= yes
1322 1322
1323HAVE_MESA_VER?= 19 1323HAVE_MESA_VER?= 21
1324.if ${HAVE_MESA_VER} == 19 1324.if ${HAVE_MESA_VER} == 19
1325EXTERNAL_MESALIB_DIR?= MesaLib.old 1325EXTERNAL_MESALIB_DIR?= MesaLib.old
1326.elif ${HAVE_MESA_VER} == 21 1326.elif ${HAVE_MESA_VER} == 21
1327EXTERNAL_MESALIB_DIR?= MesaLib 1327EXTERNAL_MESALIB_DIR?= MesaLib
1328.endif 1328.endif
1329 1329
1330# Default to LLVM run-time if x86 or aarch64 and X11 and Mesa 18 or newer 1330# Default to LLVM run-time if x86 or aarch64 and X11 and Mesa 18 or newer
1331# XXX This knows that MKX11=no is default below, but would 1331# XXX This knows that MKX11=no is default below, but would
1332# require splitting the below loop in two parts. 1332# require splitting the below loop in two parts.
1333.if ${MKX11:Uno} != "no" && ${HAVE_MESA_VER} >= 19 1333.if ${MKX11:Uno} != "no" && ${HAVE_MESA_VER} >= 19
1334MKLLVMRT.amd64= yes 1334MKLLVMRT.amd64= yes
1335MKLLVMRT.i386= yes 1335MKLLVMRT.i386= yes
1336MKLLVMRT.aarch64= yes 1336MKLLVMRT.aarch64= yes